Secure Domain setup with new jicofo version


the Secure Domain setup according to the handbook (Secure Domain setup · Jitsi Meet Handbook) is not possible anymore, as jicofo has some changes and the file /etc/jitsi/jicofo/ does not exist anymore. Could you please advice how to do the changes in the new jicofo version?


You can create the sip file or use the new config file (I didn’t test it but it should work)

For example

hocon -f /etc/jitsi/jicofo/jicofo.conf set jicofo.authentication.enabled true
hocon -f /etc/jitsi/jicofo/jicofo.conf set jicofo.authentication.type "XMPP"
hocon -f /etc/jitsi/jicofo/jicofo.conf set jicofo.authentication.login-url "your-url"

See reference

Thank you for the fast reply.
I tried both versions (your code for jicofo.conf and creating the sip-file), but there is no logon message for the moderator, I still just join the room.

I tested and it works for me. Did you restart the services?

I restarted the services.
I found the problem, I had a typing error in the url, now it works.

Thank You very much. I was searching this only. It Worked.

1 Like