Secure Domain setup not working for me

Thank you for the efforts of many that provided the software used on my personal (family and friends) conference server since March. It has been really good until Chrome 86.

I apologize if this seems excessive in length.

I have successfully installed 3 Jitsi Meet servers on Debian hosts: One for personal use (March 2020), one for a local computer user group (April 2020), and one for a client (Mid-August, 2020). In each case I configured it as a Secure Domain with anonymous guests, meaning that the host or moderator for a conference must authenticate, but others need only know the conference URL to connect. The setup required to make these three servers work was so similar that I did not notice any differences at the time.

Last week, I ran into the Chrome 86 issue when using the personal server. I read a little bit on the forums, clearly an upgrade was needed. As a long-time Debian user I fired off an aptitude safe-upgrade. It became clear that was not the path to success. It wasn’t that difficult to get this going the first three times, so it seemed reasonable to apt purge, delete leftover files as needed, and start from scratch.

(The user group server has been overcome by events, and won’t need an update for Chrome 86).

I discovered the new (to me) ‘The Handbook’, and followed the instructions for the Debian Install, and the further instructions for a Secure domain. Overall, those seem pretty similar to what I used previously.

Well, I am not being prompted for a username and password when I connect, so that part is not working. Some more poking around, and I found these instructions:

Ok, so I ripped out Jitsi meet, installed and configured the newer prosody, and then re-installled Jitsi meet.

Still no username/password prompt,

And Jicofo is pretty unhappy, with a half-megabyte log file in less than an hour, errors like (there’s a stack trace, too, of course):

Jicofo 2020-10-15 20:12:14.159 SEVERE: [29] org.jitsi.meet.ComponentMain.log() java.net.SocketTimeoutException: connect timed out, host:localhost, port:5347

If the stable version from Mid-August has the fix needed for Chrome 86 (I came across a comment in the forums that the fix was committed in mid-July), and I could figure out how to grab those Debian packages, that could be a work-around for me. At least for a while, and if ‘a while’ would get me another 6-7 months that could seem pretty good.

Or of course, a pointer to additional configuration information that would let me clear up this problem would also be great.

Regards,

This only helps me, not others, but /var/cache/apt/archives on the working server from August. (if, in fact, that has the fix needed for Chrome 86)

Executive summary: Grabbing the .debs from the working server from August and putting them on the server from March made it work again. Just got that finished. That’s not enough to help someone else, but I have to work tomorrow morning so the details will have to wait.

Here’s what worked for me, to set up a server with the ‘Secure Domain’
feature, where you must be authenticated to open a new conference.
Others can join the conference without
authentication. With luck, perhaps this will work for another 6 or 7 months.

Save a copy of the existing config files that I had edited for reference.

aptitude purge jitsi-* and jicofo packages.
aptitude purge prosody.
upgrade server from Debian 9 to Debian 10
install prosody

Grab these packages from the server I set up in mid-August:
jicofo_1.0-612-1_all.deb
jitsi-meet_2.0.4857-1_all.deb
jitsi-meet-prosody_1.0.4289-1_all.deb
jitsi-meet-web_1.0.4289-1_all.deb
jitsi-meet-web-config_1.0.4289-1_all.deb
jitsi-videobridge2_2.1-273-g072dd44b-1_all.deb
and put them into a local repository.

Add the local repository to sources.list:
deb [trusted=yes] file:///var/local/deb-repo/ ./

Proceed with the install, following the procedure in


as of 16 Oct 2020.

Your mileage may vary, of course.