Secure domain not working

I recently had the same problem: secure domain was not working. This post is my story, submitted with the hope that it will help others, or perhaps inspire the maintainers with ways to provide improved diagnostics and/or docs.

I followed the instructions at Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet to install on a fresh Ubuntu 23.04 VPS. Initially this did not work. I saw errors like “Client disconnected: sslv3 alert certificate unknown” in the /var/log/prosody/prosody.log file, which suggested to me that some process didn’t find out about the new SSL Certs in time during the install. So I rebooted, and that resolved the first issue. Jitsi worked.

But it still allowed anonymous users to create new chatrooms.

I literally went through the procedure at Secure Domain setup | Jitsi Meet four separate times. Everything seemed correct. And still, anonymous users could create chatrooms.

Then I had a colleague check my work. He discovered that I had misspelled “enabled” as “enable” (I omitted the “d”) in /etc/jitsi/jicolo/jicofo.conf. Fixing that typo and rebooting resolved the issue. Now only people with a username/password can create new chatrooms.

Great software. Thanks for making it available for free. But, I wonder is there anything you can do to make it less susceptible problems due to small hard-to-notice typos in config files? Or perhaps provide an option to spew forth lots of debugging diagnostics? Perhaps debugging diagnostics are already available, in which case perhaps you can come up with ways to make documentation about the debugging diagnostics easier to find?