Secure domain - no login-password asked

Hello

I want to restrict channels creation to registered users, but guests should be able to join created channels (provided they got a channel’s password)

so,

I’ve followed this guide and I never get asked for a password when creating a room.

Am I being stupid or something? '))

Meet config
https://pastebin.com/jsPp0aVU

Jicofo sip. properties
org.jitsi.jicofo.auth.URL=XMPP:mysite.xyz

Prosody config
https://pastebin.com/mVXiUpZi

created a user with prosodyctl register username mysite.xyz password

restarted everything

/etc/init.d/jicofo restart && /etc/init.d/jitsi-videobridge restart && /etc/init.d/prosody restart

Regards.

PS unstable version +nginx

So, is the guide outdated?

I’ve followed the secure domain mini-guide to a T. As far as I can see there is no “,” missing or anything (the config files content is available in the first post)

Actually here is the thread ([jitsi-users] Secure Domain) with the same problem The topic starter had to disable anonymous domain completely to make it somewhat work but guests wouldn’t be able to join created channels anymore.

I just tested it and it works fine here. Created new VM with clean deployment followed the guide and it worked as expected.
Double-check your jicofo config file. Do you see this output:

# grep "org.jitsi.jicofo.auth.URL" /var/log/jitsi/jicofo.log
Jicofo 2019-11-15 10:04:07.354 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.auth.URL=XMPP:meet.damencho.net

Double-check prosody config and the restart order is more efficient if it is in the opposite direction.

Just copy-paste grep “org.jitsi.jicofo.auth.URL” /var/log/jitsi/jicofo.log ?

It doesn’t show anything. What does it mean?

Cheers

That either you haven’t put the setting in the jicofo config, or you did it in the wrong file, or the jicofo user cannot read that file for some reason …

Ah! I think you are onto something!.. Could you help me out with permissions?

  1. /etc/prosody/conf.avail/
    all files got root/root rw rr

2)/etc/jitsi/jicofo/
all files got jicofo/jitsi rw rr

  1. /etc/jitsi/meet/
    all files got root/root rw rr except for the key it’s rw

4)/etc/jitsi/videobridge/
all files - jvb/jitsi rw rr

Is this correct?

I think when I recreated deleted config files permissions got screwed up.

I changed them to what I posted above and it seems to be working now =)

Thanx for pointing me out in the right direction.

I have the file owner and group permission as its mentioned above. But when I try to access am not prompted with username and password for creating rooms. Only it asks for password is without mentioning room name If I hit GO button then it prompts for the password.

I used this URL https://github.com/jitsi/jicofo#secure-domain as documentation.

Please ignore my previous command, now my setup asks prosody credentials for all the rooms. I changed config.js file in jitsi-meet and it works.

Thanks.