Secure domain : couldn't start a meeting CONFERENCE FAILED: conference.authenticationRequired

i tried secure domain using these steps.

. I registered as a prosody user. Now the auth window is coming in my hosted domain, But I couldn’t log in to the secured domain. Now am not able to create a room. Whenever i trying to log in , The window is stuck at ‘obtaining session id’ I think session-id is coming from backend , i can see it in JS console. am getting the following error in console.

<ne._onConferenceFailed>: CONFERENCE FAILED: conference.authenticationRequired.

Complete Js console:
app.bundle.min.js?v=139:175 2021-04-22T15:59:00.352Z [conference.js] <ne._onConferenceFailed>: CONFERENCE FAILED: conference.authenticationRequired
o @ app.bundle.min.js?v=139:175
app.bundle.min.js?v=139:175 2021-04-22T15:59:01.837Z [conference.js] <ne._onConferenceFailed>: CONFERENCE FAILED

is Prosody global or local need any extra configuration? am pretty sure that am followed everything right. Does anything want to take care of?

Note: I build jicofo from the source. it was working before adding secure domain.

Share your prosody config, please

domain.cfg.lua.txt (3.8 KB) global prosody.txt (10.2 KB)

@damencho, This is the config files. am sure that i changed also. This is the major error.

Now am facing a different error , i followed someone’s suggestion in community

After changing the focus password, Now am getting " SASLError using SCRAM-SHA-1: not-authorized" in the Jicofo log. so mute participants are not working for the moderator. I read, your suggestions Here. But still am stuck.

My major problem is The first error.

Note: Earlier, Am Build jiCOFo from source to implement unmute option.i hope you remember it

am totally confused about the configuration at jicofo, JVB, prosody.

Once I get rid of these two errors, the project finished!

You cannot run latest jicofo like xmpp component:

Component ""

And your config is configured jicofo to be used as a component. If you update debian packages they will take care of the config.

If you want to use jicofo from source match the version you use.

1 Like

@damencho , Wowow! worked after updating Jitsi components. Many thanks