Secure domain config asks login for everyone


#1

Hi all,
I’m missing something obviuos here :slight_smile:

I have a quick-install jitsi config running on debian.
I followed the instructions on how to create a secure domain.

When creating a conference, jitsi asks me for user/password.
After creating a conference, when other users are trying to connect to the conerence they also need a login…

Where to start looking for what I did wrong??

Tim


#2

Did you add anonymous domain entry in config.js and its entry prosody config (the guest.jitsi-meet.example.com from examples)?
Open https://yourdeployment.com/config.js to make sure you see the change.


#3

I think I did it right:

conf.mydomain.be is our 'landing page":

part of my config.js:

hosts: {
        // XMPP domain.
        domain: 'conf.mydomain.be',

        // When using authentication, domain for guest users.
        anonymousdomain: 'guest.conf.mydomain.be',

        // Domain for authenticated users. Defaults to <domain>.
        // authdomain: 'conf.mydomain.be',

        // Jirecon recording component domain.
        // jirecon: 'jirecon.conf.mydomain.be',

        // Call control component (Jigasi).
        // call_control: 'callcontrol.conf.mydomain.be',

        // Focus component domain. Defaults to focus.<domain>.
        // focus: 'focus.conf.mydomain.be',

        // XMPP MUC domain. FIXME: use XEP-0030 to discover it.
        muc: 'conference.conf.mydomain.be'
    },

#4

Check this in your prosody config, do you have it and have you restarted prosody after adding it.
Also check in jicofo’s sip-communicator.properties you have

org.jitsi.jicofo.auth.URL=XMPP:conf.mydomain.be

and that jicofo was restarted after adding it.


#5

sip-communicator.properties is verified and OK.

Prosody config: this one is not clear to me: I have opened prosody.cfg.lua but there is no reference to mydomain.be hosts in that file? Only Virtualhost entry is example.com, but that one is disabled.
At the end there’s an Include “conf.d/*.cfg.lua”, conf.mydomain.be.cfg.lua in that folder is configured as described above.

To be sure, I already rebooted the server. But login stays…


#6

I’m out of ideas. Which prosody version are you using?


#7

I downloaded the latest stable this morning and performed a quick-install


#8

dpkg -l | grep prosody? The prosody version comes from the debian/ubuntu repository you use, as you are not mentioning the version of OS you are using, I’m not sure which one is that, I was just wondering can it be that this is the problem, using a version which is not widely tested …


#9

ii jitsi-meet-prosody 1.0.3216-1
ii prosody 0.9.12-2+deb9u2


#10

Did you remember to change the config.js in /etc/jitsi/meet/ (and not the one inside /usr/share/jitsi-meet)? If I recall correctly, I made that mistake.


#11

Don’t now what I did wrong, but I ended up reinstalling from scratch, and got it working