SeaMonkey not supported unless the User String pretends its Firefox

I tried to access a jitsi meet site using SeaMonkey and it came back with “It looks like your are using a browser we don’t support. Try Chrome or Firefox”

SeaMonkey is based on Firefox and is kept well up to date so not sure why it is not supported.

I normally use SeaMonkey with the User String set to SeaMonkey.
Changing the User String to say Firefox then enables the jitsi meet screen to be shown.

Could SeaMonkey be added to the supported list of browsers so it can work without having to pretend to be Firefox when its core software is from Firefox but kept much simpler and using a lot less memory.