Script for SSL certificate creation broken on 20.04 Focal Fossa

Thanks Franky1. Just ran into this problem as well on 20.04

You are a life-saver to me as well! It worked for me.
Should be careful on the bleeding edge new 20.04 release. I learned my lesson this time.

Actually I was not exactly looking to solve this issue since desktop browsers all worked ok.
I had the problem that iPhone app complained about “You have been disconnected. Please check your network connection.” Or “Reconnecting in 15 seconds…” I got the hint from Safari browser access page and had the chance to see the certificate complaint that the certificate is no-good or expired. That was unexpected and that was the reason I found myself here.

Guess what, I got rid of the " python-virtualenv" problem and ALSO got the iphone app to work alright!

There were some threads about the iPhone/Android issues and I bet some of them are related to this. Especially when mysteriously things stopped working for no good reason. Their /etc/cron.weekly/letsenscrypt-renew should be manually tested. That might have failed when the cert expired, and mystery cannot be explained.

For all the impatient Ubuntu 20.04 users, here is a good step by step guide that also covers the issues about certbot:

1 Like

In Ubuntu 20.04, apt / apt-get installs certbot in /usr/bin/. The script expects certbot to be at /usr/sbin. I did a symbolic link to solve this issue sudo ln -s /usr/bin/certbot /usr/sbin/certbot.

Hope this is of help.


This worked for me. Thanks!

I met this issue today and I found a simple solution for Ubuntu 20.04. The solution is

don’t use certbot-auto and just use the certbot version that is installed by apt.

for example, you are originally running this command

./certbot-auto certonly --manual -d * -d --preferred-challenges dns-01 --server

change it to

sudo certbot certonly --manual -d * -d --preferred-challenges dns-01 --server

It works for me. Hope it can help the others.

Just an addition: you might need to change the occurrences of ./certbot in the script to certbot and disable wget certbot_auto script lines at the beginning of the script.