Screensharing stopped working in chrome based browsers


after upgrading to the latest jitsi-meet version (I think it was the latest, I skipped the version before) screen sharing does not work anymore in chrome browsers. In Firefox browser it works.

In chrome (v 96 and v97 beta) and MS Edge the sharing dialog also looks normal, I can select the tab or whole screen and so on… and then just a black screen is shared.

This is the latest entry in the js console:

2021-12-15T21:01:34.576Z [conference.js] Screen sharing started

I can’t figure out what is going on.

Thanks for any help :slight_smile:

So you repro the same on

Thanks damencho for the reply.

It works on the official website. Can you figure out what’s wrong with my server? Take this room for testing:

You have websocket problems.

OK what kind of websocket problems? video conferences are working fine

Video will still show, but the resolution will be poor, you’ll be missing some stats and the dominant speaker indicator will be missing. All those point to websocket problems. Your js console reports it:

Also, what version of prosody are you running? In fact, paste the output of this command:

dpkg -l "jitsi-*" "jicofo*" "prosody*" | egrep '^ii'


ii jicofo 1.0-832-1 all JItsi Meet COnference FOcus
ii jitsi-meet 2.0.6726-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.5675-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.5675-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.5675-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.5675-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-595-g3637fda4-1 all WebRTC compatible Selective Forwarding Unit (SFU)
ii prosody 0.11.10-1~bionic1 amd64 Lightweight Jabber/XMPP server

I made an update to prosody 0.11 in the end of 2020 to support the “mod_speakerstats” module. I modified this module to report joining and leaving a conference to an external service.

That modification is causing errors in your deployment. You’re getting a ton of ghost users that persist in the meeting room even after everyone leaves.

Are you sure? It is just a single http request on occupant_joined and occupant_leaving. I know this problem, but I don’t have any ghost users.

I tested your deployment. There were several ghost users. Even when I closed the browser and re-launched, there were ghost users waiting in the room.

OK now there are ghost users, I do not experience this problem in “normal usage”.

So what ist the problem, prosody version 0.11 or my modification? Can you show me how to fix my modification of mod_speakerstats?

Your prosody version is fine, so the issue must be tied to the modification you made. You can try reverting the changes you made to see if that fixes it.

Was curious about ghost users so I joined to have a look, and quickly realised my presence could have been mistaken as yet another ghost :ghost:. Sorry…

I disabled my modification, the errors persist in the log.

@shawn No, you’re good. There were actually ghosts… lol. I saw that before I commented earlier.

Did you restart services after making the change?

AFAICT, you have 2 problems - ghost users and websocket issues.

Ghost users appear to have been caused by your customization.

Websocket errors - check your nginx log for clues on the cause.

Yes, I did a restart of all services.

In the nginx error log there are no entries for today :frowning:

Maybe I will set up a new, clean jitsi-meet instance later to do some testing. When I do a fresh install of jitsi-meet now, is prosody 0.11 included or do I have to do the manual update procedure?

Yeah, a fresh instance will be an easier option. Use Ubuntu 20.04; that comes with Prosody 0.11 for sure.

Thank you very much! I will do and reply in 1-2 days here. I made so many modifications during the last 2 years, maybe I break something :slight_smile:

I just did a fresh reinstall. No more websocket errors, screen sharing works in chrome. Thats good. But all the modifications I do to the file “mod_speakerstats_component.lua” are ignored.

I had a look in the changelog:

(speaker-stats) add speaker stats feature to native

Does this mean, that modifying the mod_speakerstats_component isn’t possible anymore? I know it is not a good idea to modify core plugins :slight_smile: I will create my own plugin.