Screensharing on jitsi 6.2.2 android SDK wrong resolution


I have an Android app using Jitsi SDK 6.2.2. When it is receiving screen sharing video, it is visible only on part of the JitsiMeetView in my app, regardless of what app is doing the sharing, mobile app or desktop Chrome web app.

When video is from camera, video is rendered on full width and height of JitsiMeetView in my app.

This did not happen with same application using Jitsi SDK 5.1.0.

Did anyone encounter this?


That might be due to pinch to zoom. When a desktop is received we allow pinch-to-zoon so the user can focus on the area more relevant to them.


I just tried it, it seems to be correct. How do we disable this feature programatically, and make it full screen?

I have few subquestions:

You say “desktop”, our sharing device is also android. Did you mean desktop desktop, or screen capture of android device also?

When we start receiving screen share video, it is not full screen, even though we do not touch the view and not zoom. Webrtc log is:
04-10 12:39:22.725 4726 4726 I org.webrtc.Logging: SurfaceViewRenderer: : updateSurfaceSize . Layout size: 0x0, frame size: 1920x1080, old surface size: 1099x618 enableFixedSize=true

Is it correct way to disable it, to change in (6.2.2 code) jitsi-meet/react/features/large-video/components/LargeVideo.native.js line 243 to zoomEnabled = { false }?
I did not find any other places in code where it is set. I also found no java API to do it.

We are currently not using pinch to zoom, and we do want screen share video to occupy full size of JitsiMeetView. We take care to make JitsiMeetView have exact aspect ratio of captured screen share video frames. In 5.1.0 it would occupy entire JitsiMeetView with letterboxing.

After i set the zoomEnable to false I see the following message: I org.webrtc.Logging: SurfaceEglRenderer: : surfaceChanged: format: 4 size: 1278x718

Do you how to fix it to be 1280x720 ?


It’s not possible to do that.

I mean any screen share stream, regardless of its origin.

This is expected, because we render it that way if it’s an screen-share.

Yes, there is no API for it. I think setting zoomEnabled to false would do what you expect, yeah.