ScreenShare low FrameRate and maxHeight apparently ignored

Hey there.
I’m currently in the process of hosting jitsi-meet on a netcup root-server.

system
       _,met$$$$$gg.          crashdummy@codepotatoes.de 
    ,g$$$$$$$$$$$$$$$P.       -------------------------- 
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux 10 (buster) x86_64 
 ,$$P'              `$$$.     Host: KVM Server RS 1000 SSD G8 
',$$P       ,ggs.     `$$b:   Kernel: 4.19.0-18-amd64 
`d$$'     ,$P"'   .    $$$    Uptime: 5 hours, 10 mins 
 $$P      d$'     ,    $$P    Packages: 948 (dpkg), 4 (snap) 
 $$:      $$.   -    ,d$$'    Shell: bash 5.0.3 
 $$;      Y$b._   _,d$P'      Terminal: /dev/pts/0 
 Y$$.    `.`"Y$$$$P"'         CPU: Intel Xeon Gold 6140 (2) @ 2.294GHz 
 `$$b      "-.__              GPU: Vendor 1234 Device 1111 
  `Y$$                        Memory: 2000MiB / 7978MiB 
   `Y$$.
     `$$b.                                            
       `Y$$b.
          `"Y$b._
              `"""

config.js
/* eslint-disable no-unused-vars, no-var */

var config = {

    hosts: {
        domain: 'jitsi.codepotatoes.de',
        anonymousdomain: 'guest.jitsi.codepotatoes.de',
        muc: 'conference.<!--# echo var="subdomain" default="" -->jitsi.codepotatoes.de'
    },

    bosh: '//jitsi.codepotatoes.de/http-bind',

    testing: {
        capScreenshareBitrate: 0
    },

    enableNoAudioDetection: true,
    enableNoisyMicDetection: true,
    startAudioOnly: false,
    startWithAudioMuted: false,

    constraints:
    {
        video:
        {
           frameRate:
           {
             min: 30,
             max: 60
           },
           height:
           {
             ideal: 720,
             max: 1080,
             min: 240
           }
        }
     },
    videoQuality:
    {
//      preferredCodec: 'VP9',
        minHeightForQualityLvl:
        {
            360: 'standard',
            720: 'high'
        }
    },

    disableSimulcast: false,

    enableLayerSuspension: true,
    desktopSharingFrameRate:
    {
         min: 30,
         max: 60
    },
    channelLastN: -1,
    enableTcc: true,
    enableWelcomePage: true,


    p2p: {
        enabled: true,
        stunServers: [
            { urls: 'stun:jitsi.codepotatoes.de:3478' },
        ],
//      preferredCodec: 'VP9',
        preferH264: true
    },

    doNotStoreRoom: true,
    mouseMoveCallbackInterval: 1000,
    makeJsonParserHappy: 'even if last key had a trailing comma'

};

I am facing the following issues.

Using the cam I always get about 30fps with a decent quality.
Sharing the screen however sucks really bad and despite all the threads I cant figure out why.
The video stutters really bad ( 10-15 fps dropping to 5fps ) with enforcing VP9 making it even worse…

Somehow the constraints are not respected ( streams in 2560x1440 despite maxing 1920x1080 in the settings ).

I followed the steps of the self-hosting guide and apart from the sharing problem everything else works as expected…

I tried a lot of “tricks” mentioned in this forum but this is the latest config and still does not work

Desktop streams don’t follow the camera constraints.

Didnt knew that, sorry…
My Server should however be able to handle the load.
The stream stutters with 5 fps while the server is not even close to its limit ( about 10% cpu and ram ).
The InternetSpeed should be about 800-1000 Mbit, which should be enough bandwith to handle the traffic.

I dont quite get why the performance with VP9 is worse than with VP8 or H264.
Am I missing some settings ?

Can you run a test on meet.jit.si and see if you experience the same issue?

yup the same problem.

What happens if you change the framerate from the ‘More’ tab in settings?

Screen Shot 2021-12-11 at 5.40.15 PM

There was an update with jitsi today for debian.
Didn’t test VP9 but I could now stream with 30fps on VP8.

These settings dont change a thing.
Still 5-6 fps for me.

When I just share my desktop or my ide I can get a lot of fps but as soon as I try to stream a game the fps go down…

So you’re only experiencing the issue with VP9 then? I know there was some work done on screensharing yesterday.

The problem is really bad using VP9.
I want to stream with 60fps and that does not work with the other codecs as well.
With the latest update I can get about 30fps but not 60…

The Server and my PC should be able to handle the traffic…

I’m not sure screensharing is set to allow 60fps. I think the max is 30fps, but I could be wrong.
VP9 demands more CPU and that would often downscale streams if the client is not powerful enough.

That is possible and I need to check this when I’m again on wednesday :laughing:

I am ( often ) not able to share my screen on my Windows 11 machine so all testing is done using my main Computer ( Surface Pro 7 running Pop OS ).
Its highly likely that it cant handle that high load.

With the current settings however not even the surface is at its limit while still streaming at only 5 fps

Have the same problem (VP9, max 6fps@1920x1080, regardless of UI settings or config.js).

This is not new, I’ve been having this issue since before release 5390-3.

Using meet.jit.si has the same issue. This looks like something on the client side.