Screen showing gey colur


I have used the above link to install jistsi and jibri atlast I’m getting a grey colour blank screen. how can i solve this.

We’ll need some logs to help you.
Check the browser console (F12) for errors.
Check your /etc/jitsi/meet/DOMAINNAME-config.js for errors, especially in the part where you enable the recording service - there could be a syntax error.
Check the jibri logs to see if Jibri is starting OK - if it is, then the error should be in your config,js.

Okay, so you have an error in config.js and that’s why it’s not being loaded.
Check the part of it where you edited it to enable the recording service - you have an error there. You either have a missing end-of-line comma or you have uncommented a line from a block without uncommenting the block itself… or something like this.

// recordingService: {
// // When integrations like dropbox are enabled only that will be shown,
// // by enabling fileRecordingsServiceEnabled, we show both the integrations
// // and the generic recording service (its configuration and storage type
// // depends on jibri configuration)
enabled: true,

//     // Whether to show the possibility to share file recording with other people
//     // (e.g. meeting participants), based on the actual implementation
//     // on the backend.
//     sharingEnabled: false,

//     // Hide the warning that says we only store the recording for 24 hours.
//     hideStorageWarning: false,
// },

// DEPRECATED. Use recordingService.enabled instead.
// fileRecordingsServiceEnabled: false,

// DEPRECATED. Use recordingService.sharingEnabled instead.
// fileRecordingsServiceSharingEnabled: false,

// Local recording configuration.
// localRecording: {
//     // Whether to disable local recording or not.
//     disable: false,

//     // Whether to notify all participants when a participant is recording locally.
//     notifyAllParticipants: false,

//     // Whether to disable the self recording feature (only local participant streams).
//     disableSelfRecording: false,
// },

// Customize the Live Streaming dialog. Can be modified for a non-YouTube provider.
// liveStreaming: {
//    // Whether to enable live streaming or not.
     enabled: true,
//    // Terms link
//    termsLink: '',
//    // Data privacy link
//    dataPrivacyLink: '

hiddenDomain: 'recorder.',

Here is small portion of config.js

  1. I edited recording server:

enabled from false to enabled: true,

  1. edited liveStreaming

edited from false to enabled: true,

  1. hiddenDomain: ‘recorder.’,

I exactly follow the link TUTORIAL - How to Install the NEW JIBRI. now getting error

You have to enable the whole block, not just one line inside it:

recordingService: {
   enabled: true,

same goes for livestreaming:

liveStreaming: {
     enabled: true,

Please see the screen-shot

Again I’m getting the same error, please see the log

It’s not the same error.
Was Jitsi Meet working before you installed Jibri?
Also check the server logs (in /var/log/jitsi/*) for errors.

Use a real domain, you are going to run into all sorts of trouble by using an IP address,

First I installed jitsi that is working fine, When I installed jibri getting this error.
I’m doing this in same server

Jibri will open Chrome and it will get a certificate error because you don’t have a valid certificate for the domain.

Added valid domain setup SSL also. Please help to solve this issue

Please share the JS console logs.

Check the jicofo logs, it left the conference.

Hello Team,

Grey colur blank screen issue resolved, Now when we start record its showing “failed to start”, I checked the “jicofo.log” and found the below error.

Jicofo 2023-02-15 02:32:39.260 WARNING: [33] JibriIqHandler.handleRequest#66: Jibri IQ not accepted by any conference:

From the console I’m showing this error also.

Please help to solve this error.

Check the Jibri log

please see the log.2.txt

2023-02-15 03:08:30.215 FINE: [18] WebhookClient$updateStatus$1.invokeSuspend#109: Updating 0 subscribers of status
2023-02-15 03:08:35.053 WARNING: [31] [] MucClient.lambda$getConnectAndLoginCallable$9#631: Error connecting:
org.jivesoftware.smack.SmackException$EndpointConnectionException: The following addresses failed: ‘RFC 6120 A/AAAA Endpoint + [] (’ failed because: connect timed out
at org.jivesoftware.smack.SmackException$EndpointConnectionException.from(
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectUsingConfiguration(
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectInternal(
at org.jivesoftware.smack.AbstractXMPPConnection.connect(
at org.jitsi.xmpp.mucclient.MucClient.lambda$getConnectAndLoginCallable$9(
at org.jitsi.retry.RetryStrategy$
at java.base/java.util.concurrent.Executors$
at java.base/
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/
2023-02-15 03:08:50.719 INFO: [44] InternalHttpApi$internalApiModule$2$1$1.invokeSuspend#58: Jibri gracefully shutting down
2023-02-15 03:08:50.755 INFO: [45] MainKt$main$gracefulShutdownHandler$1.invoke#111: Jibri has been told to graceful shutdown, waiting to be idle before exiting

"may I know this issue because of lets encrypt?

It says it’s timing out, jibri can’t connect to prosody.
What’s in your jibri config, how do you connect to xmpp? Here is an example jibri/example_xmpp_envs.conf at master · jitsi/jibri · GitHub

Can you reach 5222/tcp on the main machine from the jibri machine?

I’m using jitsi and jibri in same machine[ubuntu 20]