Screen Sharing option disabled even after desktopSharingChromeDisabled set to false

I Installed lib jitsi meet from https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md and uses it as my media server.The Audio/Video calling options works really fine. But the Screen sharing option in the Jitsi Audio/Video calling Widget is disabled even after I set the desktopSharingChromeDisabled flag to ‘false’ in the config files( /usr/share/doc/jitsi-meet-web-config/config.js and /etc/jitsi/meet/media.mycompanyname.com-config.js)The flag desktopSharingChromeDisabled was originally commented in these files.I uncommented it and also set it to false to enable the screen sharing in chrome.I restarted Jicofo,Jitsi Videobridge and Prosody to effect these changes.Still the Screen Sharing option is Disabled in the widget window.

What could be a possible solution?Kindly help

What is the browser and version that you use?

Chrome Version 62.0.3202.94 , ubuntu 18.04

To use chrome so old, you will need to create an extension and publish it in chrome webstore and install it on all computers using that old chrome https://github.com/jitsi/jidesha. Newer chromes does not require extension, you better update it, it is 2 years old anyway.

Hi ,

I tried in Google Chrome Version 77.0.3865.90 in Windows 10 and Windows 7 machines.Even it has the same issue.

Have you removed desktopSharingChromeDisabled from your config.js?

Originally it was commented in the config.js.I uncommented it and set it as false itself in the hope of making screen sharing work. But that did n’t change anything.

I just created new VM in DO, followed the quick install opened the page and I see:
image

root@ubuntu-s-1vcpu-1gb-lon1-01:~# history
    1  echo 'deb https://download.jitsi.org stable/' >> /etc/apt/sources.list.d/jitsi-stable.list
    2  wget -qO -  https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
    3  apt-get update
    4  apt-get -y install jitsi-meet
    5  history

Running latest chrome:

Google Chrome is up to date
Version 77.0.3865.90 (Official Build) (64-bit)

That was so nice of you damencho…Really appreciate the effort…

The area I have issue is the widget .You can see that the Start Screen Sharing is disabled in the Jitsi widget.screenshotjitsiwidget|282x322

Even I get the screen sharing option when I just run the jitsi meet as a standalone application.Problem is only in the Jitsi widget as I mentioned in the original post .When I use this installed jitis meet for my video call this option is just disabled.

I have no idea what is this widget and how it works, where it runs, what modifications does it apply over jitsi-meet … the button in current jitsi-meet for screen sharing checks whether the browser supports webrtc getDisplayMedia method, which modern Chrome and Firefox does and just enables it and it is working …

OK Cool…I am newly assigned to maintain a Jitsi implementation which was working fine (Even the screen sharing) till the jitsi meet implementation was changed recently.So I really thought it was something to do with Jitsi only.

Anyway let me check over it in more detail.Really appreciate your effort so far …Thanks a lot.