Screen sharing not working in LAN


#1

I have tried to install jitsi from stable, testing and nightly repos, but every time I did not see screenshare button. I know I needed special extension, but I got feeling that after 72 Chrome it is not needed anymore (my chrome is in recent 72).
When I run in docker, extension is not needed and I can see the button, but we experience connectivity issues when 3 more participants join (JVB Failed to set the TL0PICIDX of a VP8 packet)
I tried firefox as well without docker, screen share button there, but does not work, other site is not receiving.

We used to have older version of jitsi but with chrome upgrade to 71, screen share stop working and extension did not help. We are blocked and I am trying to find any workaround to have screen sharing working in our LAN

When I use https://meet.jit.si/ everything work just fine, I simply do not know how to reach similar stability in my own LAN


#2

Are you using the latest stable?

Indeed chrome 72 should be screen sharing without extension, but you need to have jitsi-meet which includes this change:

So the latest stable includes that.


#3

I installed it from stable following:


After I used stable branch, I got (dpkg -l | grep jitsi)
jitsi-meet: 1.0.3508-1
jitsi-meet-prosody: 1.0.3186-1
jitsi-meet-web: 1.0.3186-1
jitsi-meet-web-config: 1.0.3186-1
jitsi-videobridge: 1104-1

When I used testing repo:
jitsi-meet: 1.0.3229-1
jitsi-meet-prosody: 1.0.2942-1
jitsi-meet-web: 1.0.2942-1
jitsi-meet-web-config: 1.0.2942-1
jitsi-videobridge: 1077-1

with untable (nightly)
jitsi-meet: 1.0.3543-1
jitsi-meet-prosody: 1.0.3213-1
jitsi-meet-web: 1.0.3213-1
jitsi-meet-web-config: 1.0.3213-1
jitsi-videobridge: 1108-1

In any case I did not see on the left bottom panel share screen button. My browser is ok, because it works on docker and your meet.jit.si url. I cannot see any error in development tools. I used Ubuntu 18 and 16, on plain vagrant instance (“bento/ubuntu-16.04”)


#4

Have you checked config.js you may have there:
‘desktopSharingChromeDisabled: true’?

As you mention docker I remember someone submitting https://github.com/jitsi/docker-jitsi-meet/pull/58


#5

Oh, I totally missed that, sorry, I have not expected it to be turned off on purpose. It worked after that. Also I noticed in the latest unstable code it is enabled by default

Thank you. Hopefully it will be pushed as docker image soon.