Screen sharing needs to be restart to have HD when not using p2p mode

Hi ! :slightly_smiling_face:

I’m new on jitsi, I love it but I have some little issues with it.
If anyone can help me on this topic it would be great. :slight_smile:

So, I’m running jitsi on docker (https://github.com/jitsi/docker-jitsi-meet)

I’ve some issues with p2p mode (would be another topic) so I disabled it for now in config.json

My issue:

When I start a conference and share my screen (or someone share his screen), default quality is SD or LD it depends. I have to disable screen share and enable it again to have HD quality, after it’s fine.

Do you have any suggestions to investigate ?

I can provide my config if needed, just let me know, I don’t want to weigh down my first message. :grinning:

Thanks a lot,
Paco

I’ve had problems with the stable jvb and 2 person calls non-p2p. The solution for me was to disable simulcast, which is obviously not great. JVB-2, which is available in the unstable releases, also solved the problem for me and let me keep simulcast enabled while p2p was disabled.

Hi !

I tried to disable simulcast as you mentioned and effectively it works, I’ve HD directly when sharing the screen. This is a good workaround. :slight_smile:

So, in my case, I can see three solutions:

  1. Let simulcast disable in non p2p mode (with all constraints related)
  2. Activate simulcast but trying to enable p2p mode again (and solving the issue I have with)
  3. Trying to build my own image of JVB-2 to test

These solutions brings me questions for 2. and 3.

(2) In 1to1 call and p2p enable, screen sharing works perfectly but one of the two guys in the conversation has a very low framerate, that make it hard to use.The other one has a perfect quality/framerate. Do you have any suggestions to investigate on my part ? The issue doesn’t appear for the participant in non p2p mode.

(3) Is there a way to build my own image of JVB-2 using a .deb package ? As it’s yet at the unstable stage I suppose there isn’t any official docker images.

Thanks a lot for your help ! :slight_smile:
Paco

  1. I bet you’re still going through the jvb. If p2p can’t connect it goes through the jvb and then you’ve got simulcast problems when you’re 1to1. I believe there are some settings in config.js regarding screen sharing frame rate requirements, maybe those are worth a look too?

  2. I don’t have any experience with docker, sorry, I’ve just been running on Ubuntu directly. I know that the jvb-2 stuff is in the jvb master branch, you could try cloning and building yourself. I don’t know if the Jitsi developers have any documentation for the docker builds.

Pinging @jallamsetty the house screensharing expert :slight_smile:

Hi ! :slight_smile:

Thanks for your answers !

@mosatch

  1. No I’m connected in p2p mode when I enabled it, it’s not the same issue as the one with JVB on 1to1. I have the (p2p) indication on the connection quality indicator. I tried with other configurations today and I don’t have the issue for all of them. I tested with following configurations:
  • Same subnetwork (100Mb dl/5Mb up) : perfect connection 1920x1080 20-30 frames/s, both sides
  • 1 computer on my phone shared connection (~30Mb dl/~25Mb up), another on 100Mb dl/5Mb up : perfect connection, same as above.
  • 1 computer on 100Mb dl/5Mb up network, another on 200Mb dl/25Mb up : one side is perfect (computer which is connected with 200Mb dl/25Mb up), other has poor framerate (~5 frames/s)

I think connections are good enough to perform my requirements (1920x1080 20-30 frames/s).

My server is connected on a symetric 1Gb/s network.

I switch on my own STUN servers instead of google ones to initiate the connection but I don’t think it will help. I was thinking perhaps about an issue to initiate properly the connection sometimes. Perhaps STUN isn’t sufficient and I should try with a TURN server to relay the stream ? But in my mind, connection will always failed if it wasn’t the case and I couldn’t be able to see at all other participant screen. Am I right ?

  1. Ok, I will have a look to build a docker image based on JVB-2 to try to solve the jvb 1to1 issue. But I would prefer to solve point 2 and wait for JVB-2 stable builds. :smiley:

@saghul: Thanks for your contribution ! :slight_smile: Perhaps new inputs from jallamsetty soon.

I will continue to drive tests in the next days and I will post my outcomes.
I hope I will be able to stabilize this. Perhaps it could help others with these kinds of little issues too.

Thanks again for your time,
Paco