Screen sharing Failed!

Screen sharing no longer working. Used to work every time, no issues.
Now it shows pop up “Screen Sharing failed! Oops! Something went wrong with your screen sharing extension permissions. Please reload and try again.”
But reloading and retrying does not help.

Welcome to the forum.

There’s a bug in the latest version of Chrome that’s affecting Screensharing. The issue has been reported to the google team. In the meantime, you can try using Firefox instead if Chrome is still giving you issues. Alternatively, you can downgrade to an earlier version of Chrome, if you’d rather use Chrome.

Thanks for helping me, Freddie.
I’ve just tried using Safari and it seems to be working there thank goodness.
How will I know when the bug has been fixed?

Hi Freddie,

What version of Google Chrome is affecting which version of Jitsi?

Kind regards

Version 92. The team made some drastic changes to the browser that negatively impact WebRTC applications (Jitsi included). They’ve reverted some of the changes, but apparently some still linger.

The problem only occurs with VP9 and as we moved to enable VP9, because of that bug we reverted it back to VP8 and you should not experience the problem even with chrome 92 on

1 Like

Is there a way we can move it back to vp8 on our self-hosted ones?

Your self-hosted instance defaults to VP8. If you haven’t specifically configured it for VP9, VP8 should be the default.

Ok thank you Freddie.

Hello Demencho,

Does this also affect those only using VP9?

Because I could have sworn I experienced the same issues when unfortunately Google Chrome updated to v92. I was using the stable deb packages and using VP8.

Upgrading to the latest unstable seems to fix those issues with Google Chrome v92.

We had identified only the problem with 92 when using vp9 with latest versions. The latest is in testing repo and will push it to stable tomorrow.

Is this problem not solved yet? I’m experiencing it on different browsers.

  1. On Chrome [Version 99.0.4844.74 (Official Build) (x86_64)]:
    Screenshot 2022-04-01 at 18.36.35

  2. On Firefox [ version 98.0.2 (64-bit) ]:
    Button Start /Stop sharing your screen irresponsive.

  3. On Opera [Version:85.0.4341.47 (x86_64)]:

Same as Chrome.

What’s the quick fix to this?

If this is macosx go to system preferences and remove and add again the browser screen recording permissions.

Perfect. This works.

Yep, it is chrome bug which was fixed but you need to go through the permissions again.

1 Like