Screen Sharing Display Name

Hello,

I’m searching to hide the display name of the person using screen sharing.

image

It wasn’t there on the previous version I used, but now, this name stay there even when the toolbox is hidden, this cause some issues during presentation. I could use some CSS to hide it, but i wanted to know if there’s a proper way to hide it, without editing any CSS.

I didn’t find anything in the config.js relative to this “nameplate” and this is causing some issue as main users of the service are using the screen share for presentation and the name is often in front of some information.

Both solution we’re using right now are empty name, and virtual camera with a smaller size, wich is not really a good thing.

Anything about that on configs file or should I edit some CSS myself ?

Welcome to the forum.

Set this in your config.js:

hideDisplayName: true,

As far as I can tell, it is not currently possible to remove the dominant speaker name via config.

There’s the hideDisplayName config, but that appears to hide names in thumbnails but not the dominant speaker name above the toolbar. Even if it does work across the board, I’m not sure that is ideal for it to be all-or-nothing – I may want to hide in thumbnails, but show for dominant speaker, or vice versa.

@damencho would hideDominantSpeakerName be something we would consider exposing as a config var? Looks like the component is parametrised but hardcoded to always show.

I’m not so sure about this. I seem to faintly recall that setting the flag did work in a test recording I did (I believe about 4 participants in the meeting). The display names were hidden as expected. I haven’t specifically checked screen sharing though. I’ll check in my dev deployment later.

Perhaps. Looking at the code it should hide everywhere but when I quickly tried it on meet.jit.si it hid names in thumbnails and in gallery view, but name of dominant speaker still shows up above toolbar in stage view. Mind you I have not dosed up on min level of caffeine to function yet so I could be mistaken.

Even so, would be nice to have finer grain control and not have to hide names everywhere.

Naw, I just saw the file from the test recording I did. Setting the flag basically reverted to the previous behavior - no display name in stage, but name shows up for the dominant speaker in the filmstrip (which is necessary, since that thumbnail is essentially dimmed out while the speaker is on stage). So it indeed works as expected. Gotta catch some :zzz: now, but I’ll re-confirm later.

Hi, Thanks,

I tried this option, it also hide the name on the thumbnail, wich is not wanted by end users. And i’m not even sure that the dominant speaker is hidden (can’t remember what the user said).

I’ll gonna add some piece of code to hide it, but some flags could be great. I’ve seen an open issue on github talking about that : https://github.com/jitsi/jitsi-meet/issues/7057

But it seems that it was not added in the interface_config.js neither

I’ve raised a PR to propose a new config just for that i.e. hide dominant speaker badge above toolbar without having to remove names everywhere :crossed_fingers:

1 Like

Add this to the end of your all.css file in /usr/share/jitsi-meet/

#localDisplayName{visibility:hidden;}.jss45 { display:none !important; }

Just double check that .jss45 is the class name for the element you want to hide (it changes with each new jitsi version that comes out) - you do this by right clicking → Inspect element.

Then Ctrl+F5 the page (hard refresh), and the display name is gone.

Damn that was fast, thanks !

I actually managed to solve the problem with some trick with an other request from the user, moving the toolbar to the top of the screen, i placed it right under the name room (the dominant speaker badge is between)

image

The badge is hiding on top with the toolbar. I don’t know if the toolbar on top is something often requested (I don’t think so). It is just all.css editing but i’ll check if i can find a simple way to configure it with a variable.

Thanks for your help again !

No problem.

FYI, the new config has been merged and available to test in alpha deployment. For example: https://alpha.jitsi.net/CurlyCurriculaInterfereFortunately#config.hideDominantSpeakerBadge=true