Screen Sharing Disabled in unstable

Hi Everyone

I reinstalled Jitsi Meet from the unstable repo, as I need the “Mute All” functionality, which I understand is only available there.

That is a year old comment from damencho, so I may be missing something obvious.
However from unstable, it is not possible to use the screen sharing function: when hovering over the Screen share icon it says “Screen sharing disabled”. I have hunted through the config.js and it looks the same as the one from the stable repo. I think this is the relevant part:

// Desktop sharing

// The ID of the jidesha extension for Chrome.
desktopSharingChromeExtId: null,

// Whether desktop sharing should be disabled on Chrome.
// desktopSharingChromeDisabled: false,

// The media sources to use when using screen sharing with the Chrome
// extension.
desktopSharingChromeSources: [ 'screen', 'window', 'tab' ],

// Required version of Chrome extension
desktopSharingChromeMinExtVersion: '0.1',

Anyone know if there is a way to get both “Mute All” and “Screen Share” working at the same time ?

That was already pushed in stable.

OK, thanks for your quick response !!

Will reinstall from the stable repo.
It will give me a chance to check if I documented all those config changes I had made :thinking:

Thanks again for the great support you provide to the community.

@damencho Hi, I reinstalled from stable, and setup multiple domains .
The primary domain (one given during install) has screen sharing enabled and working, but secondary domains, although enabled in interface_config.js does not work. Hovering over the button gives “Screen Sharing Disabled”.

TOOLBAR_BUTTONS: [
‘microphone’, ‘camera’, ‘closedcaptions’, ‘desktop’, ‘fullscreen’,
‘fodeviceselection’, ‘hangup’, ‘profile’, ‘info’, ‘chat’, ‘settings’, ‘raisehand’,
‘videoquality’, ‘filmstrip’, ‘feedback’,
‘tileview’, ‘download’, ‘help’, ‘mute-everyone’
],

Am I missing something obvious, or is there a limitation on multiple domains ?

Screen sharing seems disabled for me too. Can you solve it? @damencho

Share your config.js and interface_config.js