Screen Sharing causes “video turned off to save bandwidth”

We updated to [jitsi-meet 1.0.6644] yesterday and are now experiencing an issue where any user trying to screen share will result in a message to all other participants that this user has had “video turned off to save bandwidth” and their screen sharing is not displayed when in Full (eg not Tile view).

The screen share IS viewable in tile view, but not in full view. We have reduced resolution toresolution: 480 set ideal: 480 , max: 480 but this does not solve the problem.

If other participants manually change their performance settings from Highest Quality (4/4) to (3/4) the issue is resolved. Is there any recommendation to help fix this?

Any js console errors?

No JS console errors.

I have the same problem.
js console log:“sendNewReceiverVideoConstraintsMessage “e7558b19-v1”:{“maxHeight”:-1}”
My temporary solution:
react/features/video-quality/subscriber.ts
// let quality = VIDEO_QUALITY_UNLIMITED;
let quality = MAX_VIDEO_QUALITY; // Do not set -1

Who solved this problem?

@yangaphero what version of jitsi-meet-web and jvb are you using? Are those in sync?

We got a fix in play on our version by doing the following

  • Make sure latest versions of jitsi-meet-web and jvbset
  • prefer codec H265
  • made it so the video quality slider wasn’t set to max but it was set at one below max. We do this using the Jitsi iframe API with: executeCommand('setVideoQuality', 360);