Screen sharing button disabled but using screen sharing as virtual background works

Hi there, using my own server I encounter a bug with release 2.0.6726 : the screen sharing button is disabled but using screen sharing as virtual background works.

Looks like Share Screen disabled but the user didn’t spoke about virtual backgrounds and I have the same results in Chrome 96 and 97, Firefox 95 and Edge 96 (on Windows 11 21H2 or Windows 10 21H1)

jicofo 1.0-832-1
jitsi-meet-web 1.0.5675-1
jitsi-meet-web-config 1.0.5675-1
jitsi-meet-prosody 1.0.5675-1
jitsi-meet 2.0.6726-1
jitsi-meet-turnserver 1.0.5675-1

Thanks for your help!

This behavior is linked to “enableFeaturesBasedOnToken: true,” in config.js

How do you do that?

Did you set screen-sharing in the token?

1 Like

solution found here:

That means that if sharing screen is disabled in JWT, you can still use sharing screen as virtual backgrounds.

i just found it on the community. thanks!

You can use “desktop share” in virtual backgrounds:

1 Like

You can set the disableScreensharingVirtualBackground config option.