Save recording to server with JWT enabled

Hi I am trying record the meeting with jwt enabled. But unable to do that, Can any one help me.
I am following the below mention documentation.

jibri.txt (2.3 KB)

This guide is old, config params are different now.

@emrah This is the present config I have.

recordingService: {
// // When integrations like dropbox are enabled only that will be shown,
// // by enabling fileRecordingsServiceEnabled, we show both the integrations
// // and the generic recording service (its configuration and storage type
// // depends on jibri configuration)
enabled: true,
// // Whether to show the possibility to share file recording with other people
// // (e.g. meeting participants), based on the actual implementation
// // on the backend.
// sharingEnabled: false,
// // Hide the warning that says we only store the recording for 24 hours.
// hideStorageWarning: false,

Does the server-side recording work now when you disable the token authentication?


Did you disable “enable_domain_verification” in your prosody config?

This is the default case for the latest stable but not for the previous version

Yes, we disabled that.

Can you share your prosody config after masking the private data?

@emrah please find below attachments. (5.3 KB)
prosody.cfg.txt (10.5 KB)

There is no enable_domain_verification in your config

@emrah After adding the above stuff, still not working.

Can you share your current prosody config?

@emrah Please find updated attachments.

prosody.cfg.txt (10.5 KB) (5.4 KB)

You should not disable "token_verification" even though it is not related with the issue.

I couldn’t find any miss configuration. If jibri works when the token authentication is disabled, it should also work with token authentication using this config

No… it’s not working :frowning_face:

What todo

I tried with fresh installation attached the log files and conf files.

jaas.cfg.txt (424 Bytes)
prosody.cfg.txt (10.6 KB) (5.4 KB)
jicofo.log (17.8 KB)
jvb.log (101.7 KB)
prosody.log (34.1 KB)
browser.0.txt (367.3 KB)
log.0.txt (19.1 KB)

Looks like you have the following problem but I didn’t understand why it works when the token auth is disabled

config.flags.sourceNameSignaling = true;
config.flags.sendMultipleVideoStreams = true;
config.flags.receiveMultipleVideoStreams = true;
// Temporary backwards compatibility with old mobile clients.
config.flags = config.flags || {};

This is not correct. Check what I posted

As you suggested i did changes still not working.

config.flags = config.flags || {};
config.flags.sourceNameSignaling = true;
config.flags.sendMultipleVideoStreams = true;
config.flags.receiveMultipleVideoStreams = true;

// Set the default values for JaaS customers
if (enableJaaS) {
config.dialInNumbersUrl = ‘’;
config.dialInConfCodeUrl = ‘’;
config.roomPasswordNumberOfDigits = 10; // skip re-adding it (do not remove comment)