Same Jitsi-Meet instance with multiple domain names

I was able to fix my system after your message :+1:

Glad to see people healping each other out everyone is being able to run and use their own server/application.

Let us make this forum even better by sharing what we know - you never know your small tip&trick can help someone wrap up their weeks of headache. :slight_smile:

Many Thanks,
Rav

Hi @probie,

Did you install/configure Jitsi for multi-domain like: meet.abc.com and meet.xyz.com on same server or was it for only 1 domain on one server?

I need some massive help and need it pretty quickly to install multiple instances on 1 server and so you can imagine I cannot edit /etc/hosts and /etc/hostname as it will mess up my rDNS etc.

Any idea how I can proceed?

Many Thanks,
Rav

Yes, I got it working just like what you mentioned. Let me get back to you tomorrow morning (Wednesday PST timezone).

Did you resolve problem?
I have same screen on my Domain2(

Hi Raviktiwari, below are the steps that i compiles and took. This is based on default install w/NGINX and not Apache.

1.copy first instance of NGINX config file (primary domain) to the second domain
2.enable the second domain (or sites) example in this case meet.xyz.com.conf
3.edit the secondary domain(or site) and comment out “server_names_hash_bucket_size 64;” if it exist becuz it already exist on the primary config as default. If it doesn’t exist, the no worries
4.change “server_name” to new domain —> example server_name meet.xyz.com;
5.change certificate and key and point it to the location of the cert/key of the second domain(or site)
6.change the “proxy_set_header host $http_host;” under # BOSH to “proxy_set_header Host meet.abc.com;”
7./etc/jitsi/meet/meet.abc.com-config.js and change the below
8.change “bosh: ‘//meet.abc.com/http-bind’,” to “bosh: ‘///http-bind’,”
9.restart all services and test

3 Likes

For some reason, step 8 does’t format correctly when I copy and paste.but it should look like this for step 8

Hi there, I have related problem , this seems now work for me (How to configure Multidomain support for Jitsi Meet Docker ? (Behind CDN))

Thanks @probie but I am using Apache so your help does not help me as such, but I will see if I can get some hint from here.

However, if you have any code, link or suggestion on Apache, can you pls share it with me.

Thx: Rav

1 Like

Hi,

I am newbie to jitsi-meet
Can you please guide me regarding jitsi , i am trying to setup a video server.

I have installed and configured jitsi-meet and now i want to connect my android phone with this server but i am unable to do it.

Initially, i installed server and provided hostname as my IP address but it does not generate certificates with letsencrypt.sh script run at the end of installation. Then, i tried with dummy DNS name since i dont have any but still same issue.

With IP as hostname , i can conduct a conference using Desktop and URL provided in the browser but cannot do the same with android phone.

I have read somewhere that jitsi-meet does not generate ssl certificate with letsencrypt.sh script for IP address as domain name.
I do not have any valid domain name, any alternate or any solution for this?
Can you please help me in this regard?

any word will be highly appreciated

hello , i have been trying for quite a long time in setting up jitsi-meet instance with multiple domain names one local ip without any domain name + one public ip with domain name meet.example.com on ubuntu 20.04 lts , but without any success. i am thinking of downgrading to ubuntu 18.04 and try to install it gain. could you, please suggest what configurations needs to be changed.
thanks in advance

I had some trouble… but I figured it out…hope that helps somebody in the future…:wink:

For anybody, who wants to change the whole Domain name for that instance… e.g. if you have a preconfigured VM and using an own ssl Cert using Debian 10 and Apache2
This even works with JWT-Authentication

In my case… I had a Wildcard Domain Cert… as Windows pfx

Create on Windows using open ssl the following 4 certs…

“C:\Program Files\OpenSSL-Win64\bin\openssl” pkcs12 -in d:\mydomain.com.pfx -nocerts -out d:\mydomain.comkey.pem

“C:\Program Files\OpenSSL-Win64\bin\openssl” pkcs12 -in d:\mydomain.com.pfx -clcerts -nokeys -out d:\mydomain.comcert.pem

“C:\Program Files\OpenSSL-Win64\bin\openssl” rsa -in d:\mydomain.comkey.pem -out d:\mydomain.comkey.key

“C:\Program Files\OpenSSL-Win64\bin\openssl” pkcs12 -in d:\mydomain.com.pfx -clcerts -nokeys -out d:\mydomain.comcert.crt

Create a new Directory e.g. /etc/mycerts

Copy these 4 filse into the newly created folder

Change path and filenames in your /etc/prosody/conf.avail/MYJITSIDOMAIN.cfg.lua
ssl={
path/to new key;
path to new crt
}

Change path and filenames in your /etc/apache2/sites-available/MYJITSIDOMAIN.conf
SSLCERTIFICATEFILE … /etc/mycerts/cert.pem
SSLCERTIFICATEKEYFILE etc/mycerts/cert.key

Change bosh setting in your /etc/jitsi/meet/MYJITSIDOMAIN-config.js
from
bosh: ‘//myoldjitisdomain.com/htttp-bind’,
to
bosh: ‘//myNEWjjitisdomain.com/htttp-bind’,

restart
jicofo, videobridge2, prosody, apache2

Thats it

THANK YOU SOOOOOO MUCH! Been trying for hours! Just a quick note to anyone else looking up this solution. You need to remove the two Asterisks symbols before and after ’ in the /etc/jitsi/meet/server.example.local-config.js file or you will just get a grey screen.

so your file should look like this:
// BOSH URL. FIXME: use XEP-0156 to discover it.
bosh: '//<!--# echo var="http_host" -->/<!--# echo var="subdir" default="" -->http-bind',

Thanks so much Chris.d you are a saint.

1 Like

Many thanks, never mind!
I’m happy that it works!

1 Like

@damencho

I got a dual setup working so far, two domains with their specific SSL certificates can be used and was able (via nginx configuration) to use different layouts (dplucated lang, static, css directories with modified content for the second domain).

I yet failed to be able to use two different setups on prosody. As far as I understood, jicofo does not support multiple domains in one setup, so I tried to setup an independend jicofo instance but could not get this working (possibly a setup problem of the ports to use on the 2nd instance and how to configure them in the prosody setup for <domain2>).

And I was not able to determine which parts of the prosody <domain>.cfg.lua I need to keep and which ones I need to modify to use different prosody virtual hosts for both external domains.

To be more specific

Primary domain: <domain1> on nginx, prosody and jicofo with standard ports

Secondary domain: <domain2> on nginx (working) and prosody (not working), keeping jicofo on <domain1> with the standard ports or indpendend prosody/jicofo instances.

So could anyone tell me how to configure additional Virtualhosts <domain2> and guest.<domain2> in prosody (which are “domain”, “muc” and “anonymousdomain” in <domain2>-config.js in Jitsi if I am right),so I can use different settings for their <domain2> components in prosody while still using jicofo of <domain1>?

Or how I need to configure prosody and jicofo to create a complete independend instance (the two instances do not need to communicate)?

Thanks.

Hi hkaiit. Please make detailed instructions for us. Thanks

Dears,
I just configured 2 domains on 1 instance on Ubuntu server.
It’s been working with only 1 domain for a long time before and, of course, firewall configuration is unchanged.
All ok from LAN, while I have no audio and video from the Internet.
I added the certificate for 2nd domain and it is reported valid from any browsers from the Internet, I just have no streams.

Any suggestions?

Regards

1 Like

Check your console log for errors. That should be a good place to start.

Dear, sorry to bother, but I could find no logs.
Where’s console log?

Regards

I have the same problem, i follow the thread