Safari works in https://meet.jit.si/ but not when I use it with my own jitsi server

We did an install of jisti server on our own ubuntu server and Safari does not work. Scenario: I enter a meeting with Safari, all good. A second person engters the meeting and then my Safari session stops with an error message and it continually tries to reconnect. I tried the same scenario using the meet.jit.si server and I have no problems; the second person joins the meeting and my Safari session continues in the meeting without issues.

We installed jisti by following several of the tutorial sout there, no mention of doing anything special for Safari browsers. Do we need to do something special on the server to fix the issue? Anyone else ran into this? Any help would be appreciated!

Which instructions did you follow ? I’d suggest using the Quick Install instructions.

I looked at many docs but mainly followed this video and blog entry combo:


https://crosstalksolutions.com/how-to-install-jitsi-server-on-ubuntu-19-10/

Wow, that’s incredibly detailed, including the initial server setup.

I’d suggest comparing that to the official Quick Install docs, perhaps disable single firewall rules one by one to rule out errors there (I saw a few differences).

Using Ubuntu 18.04 (not 20.04) will also make it less likely you encounter older bugs or incompatibility that may have been resolved since.

Hi,
I did here and it worked.
docker-compose down
Remove all files/dirs from $HOME/.jitsi-meet-cfg/, except the lets encrypt files on “web” directory (keys and letsencrypt dirs)
docker-compose up -d

1 Like

Full safari support was added to jitsi very recently, you may need to use the unstable debian packages.

1 Like