Safari browser not listening

I am listening an android chrome browser without any problem.
BUt on my ipad safari browser i cannot listen. It can be a problem puttingthe listener microphone disable at the starting?
here is my config.

<script>
                /** CONFIG **/
                function init() {
                    //document.getElementById("startdlg").style.visibility = "hidden";
                    var channel_name = document.getElementById("channel_name").value;
                    document.getElementById("startdlg").innerHTML = "";
                    const domain = 'meet.jit.si';
                    const options = {
                        roomName: channel_name,
                        width: 1024,
                        height: 700,
                        configOverwrite: { 
                            startAudioOnly: true,
                            enableWelcomePage: false,
                            enableClosePage: true,
                            prejoinPageEnabled: false,
                            enableInsecureRoomNameWarning: false,
                            disableThirdPartyRequests: true
                             },
                        interfaceConfigOverwrite: {
                            APP_NAME: 'Guid.fm for Listener',
                            DISABLE_JOIN_LEAVE_NOTIFICATIONS: true,
                            TOOLBAR_BUTTONS: [
                                'microphone', 'hangup'
                            ],
                         },
                    };
                    const api = new JitsiMeetExternalAPI(domain, options);
                    api.executeCommand('displayName', 'Web1');
                }

            </script>