Running jitsi localhost

Hi,

I downloaded the Jitsi client from github and all the changes I make to interface_config.js appear to have made none … What should I do? After the changes I run the project with make dev

Already taking advantage of the topic, where should I change to run with the localhost Jitsi API? And which github repository should I download?

I’m starting and I feel a little lost, if anyone has a tutorial or article on Jitsi changes and running localhost, I appreciate it.

1 Like

I think interface_config.js is taken from server, if you want to serve it locally you need to change the code in the webpack config in this method: https://github.com/jitsi/jitsi-meet/blob/master/webpack.config.js#L278
You can see there how static and css are handled from local.

Hi

I have cloned jeetsi meet repo and was able to run project successfully ( npm install, make , make dev).

Now from which repo I can get source of https://api.jitsi.net? Instead of pointing at https://api.jitsi.net, I want to point on my server ( i.e want to run on my installation).

What is this?

Hi

I cloned jitsi-meet and was able to run on my AWS ec2 instance. npm install, make , make dev. When I was checking configuration file I saw my installation is using https://alpha.jitsi.net for API related things. How can I host APIs on my server?

Alpha jitsi net is deployment used by default when using webpack dev server, that deployment is always uptodate wiith latest unstable packages.

You can do WEBPACK_DEV_SERVER_PROXY_TARGET="https://myserver.com" make dev and use the webpack dev server using your own deployment.

Hi Actually I tried with that.

I have setup dummy domain (freenom) and setup https (let’s encrypt). When I use make dev it is running on https://sumeriandemo.tk:8080/. So I tried with

const devServerProxyTarget
    = process.env.WEBPACK_DEV_SERVER_PROXY_TARGET || 'https://sumeriandemo.tk:8080';

But when I try make dev , this url is just keep loading https://sumeriandemo.tk:8080 without any js console error

webpack dev server always uses localhost. This is a proxy server used by developers to develop the UI, it proxies the UI from localhost and all the rest of the system is used from some deployment as (alpha.jitsi.net).
Is this sumeriandemo.tk:8080 a deployment of jitsi-meet, done like described on https://jitsi.org/qi?

Actually I have followed steps from here (cloned jitsi-meet on my ec2 ubuntu 18.04 instance)

This is giving you just the web app, there are few serverside components you need which rewuires debian/ubuntu machine and a working dns.

Okay from where I can download/use it? Whether it is possible to customize that as well (if required?) For example Once everything is setup I want to track which users are in the meeting etc…

okay let me check. Once this setup is done I need to put https://sumeriandemo.tk:8080 for proxy target?

No, if you deploy it on sumeriandemo.tk. Then:

WEBPACK_DEV_SERVER_PROXY_TARGET="https://sumeriandemo.tk" make dev and you open the browser on https://localhost:8080

I think I am missing something, how can I run jeets-meet for forever, i.e without make dev?

I am able to successfully build project with make. Now how can I run project without make dev

Sorry I am kind of lost here. Previously it was mentioned to @robertosousa1, if we want to run interface_config from local we need to make changes in function devServerProxyBypass({ path }) {

I am not sure what kind of changes I need to make here?

Update

I tried log path , but I was not getting any config file here. I thought as css, sound etc are served from local path, config files also needs to serve from local

function devServerProxyBypass({ path }) {

	console.log("at beginning path - ",path);

This gave me just following files

at beginning path - /
at beginning path - /css/all.css
at beginning path - /libs/do_external_connect.min.js
at beginning path - /libs/lib-jitsi-meet.min.js
at beginning path - /libs/do_external_connect.min.js
at beginning path - /libs/app.bundle.min.js
at beginning path - /libs/app.bundle.min.js

P.S - I don’t want to install jitsi server for now. I just want to change UI a bit and use https://meet.jit.si for API

I created build using make and deploy necessary files on aws amplify. The first page looks okay but when I start a new meeting it gives me error like

jquery-3.3.1.js:4773 Uncaught DOMException: Failed to set the ‘innerHTML’ property on ‘Element’: The provided markup is invalid XML, and therefore cannot be inserted into an XML document.

I have tried to create source package as well source-package but still same issue. Also when I tried to run on Lamp stack first page shows perfectly and when I create room it shows error

here is screenshot showing error on my lamp stack

Here is video showing error on my lamp stack

Here is package created

Here is link of aws amplify URL

https://dev.d1kbduzs8rlzbt.amplifyapp.com/

I have done setup of jitsi over here

https://brightinsight.xyz/

Now when I run jitsi-meet in my local configuring devServerProxyTarget to https://brightinsight.xyz as suggested earlier in thread, it gives me

[HPM] Error occurred while trying to proxy request /?rCounter=4 from localhost:8080 to https://brightinsight.xyz (ECONNRESET) (https://nodejs.org/api/errors.html#errors_common_system_errors)
[HPM] Error occurred while trying to proxy request /favicon.ico from localhost:8080 to https://brightinsight.xyz (ECONNRESET) (https://nodejs.org/api/errors.html#errors_common_system_errors)

[HPM] Error occurred while trying to proxy request / from localhost:8080 to https://brightinsight.xyz (ECONNRESET) (https://nodejs.org/api/errors.html#errors_common_system_errors)

have you got any solution?

No I don’t, but it’s not blocker for me as I am making changes on my local for UI and deploying on my aws server to test

Could you please help me with the process so that I can follow the same steps because I’m not so good in React Js. I have my modified code with small-small changes on my local and I have a server where I hosted this application