Running fine, then server 504, then 502 strophe issue

The containerized version of Jitsi Meet was running perfectly on my Mac with Docker Desktop for more than a day. I now get the following error:

I did change a few things in interface_config.js to customize the UI, but it was working fine after that; so I’m not sure what went awry all of a sudden.

I did purge all docker images and started from scratch, but the error persists. Not sure how to proceed. Any insights to point me in the right direction would be appreciated.

Please follow below steps might be work for you

  1. rm -r ~/.jitsi-meet-cfg/{web/letsencrypt,transcripts,prosody,jicofo,jvb,jigasi,jibri}
  2. mkdir -p ~/.jitsi-meet-cfg/{web/letsencrypt,transcripts,prosody,jicofo,jvb,jigasi,jibri}
  3. change public domain in env.example
  4. cp env.example .env
  5. ./gen-passwords.sh
  6. docker-compose up -d

Thanks for taking the time to reply, @Raj_Yadav. Thanks to you, I’ve made progress.

The issue I’m facing now is a JS error - a strophe timeout (504) attempting to contact the bosh server…

Oddly enough, when I visit that URL directly, I get the following…

Now, how exactly do I “point my BOSH client to this URL”???

I’m guessing it’s a setting in config.js, but I’m not sure which one.

(And oh yeah, I get JS error when clicking the hang-up button, but I’d like to resolve the BOSH issue first.)

:confused:

I added consider_bosh_secure = true to the prosody config, and the error changed from 504 (timeout) to 502 (bad gateway).

I have no idea how to proceed, as this setup was working fine for the past few days (since I installed it).

When I visit the http-bind URL with a browser, it tells me it’s working. Any suggestions? :confused:

EDIT: And when I click the leave/hangup button, it throws a JS error because the room variable is undefined. It’s not clear whether that’s a symptom or a cause. :frowning:

If you have remote server then please try over there