Room issue sinc prosody 0.11.2-1+deb10u1

Hello,

We have stability problem since applying prosody upgrade 0.11.2-1+deb10u1

Room are regularly reloaded from 8/10 participants

In the Jicofo logs we find these error lines:

Jicofo 2021-05-21 08:51:20.031 SEVERE: [112] [room=test0@conference.XXXXXXXXXXX] AbstractChannelAllocator.allocateChannels#299: jvbbrewery@internal.auth$
org.jitsi.protocol.xmpp.colibri.exception.TimeoutException: Timed out waiting for a response.
at org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.maybeThrowOperationFailed(ColibriConferenceImpl.java:312)
at org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.createColibriChannels(ColibriConferenceImpl.java:252)
at org.jitsi.protocol.xmpp.colibri.ColibriConference.createColibriChannels(ColibriConference.java:97)
at org.jitsi.jicofo.ParticipantChannelAllocator.doAllocateChannels(ParticipantChannelAllocator.java:100)
at org.jitsi.jicofo.AbstractChannelAllocator.allocateChannels(AbstractChannelAllocator.java:253)
at org.jitsi.jicofo.AbstractChannelAllocator.doRun(AbstractChannelAllocator.java:172)
at org.jitsi.jicofo.AbstractChannelAllocator.run(AbstractChannelAllocator.java:133)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:829)

if we downgrade prosody to previous version 0.11.2-1 everything is fine.

The problem occurs on our production servers as well as on a fresh new installation.

If you have an idea :slight_smile:

Which exact versions do you see the problem with and which is the version with no problem? Is the latest security update? Do you have mod_limits enabled? If enabled with what settings?

Hi Damencho,

The current version of jitsi components :

jitsi-meet 2.0.5870-1
jitsi-meet-prosody 1.0.4985-1
jitsi-meet-turnserver 1.0.4985-1
jitsi-meet-web 1.0.4985-1
jitsi-meet-web-config 1.0.4985-1
jitsi-videobridge2 2.1-492-g5edaf7dd-1

But, we have the same problem with a outdated server since few month

Everything works with this version of prosody

prosody 0.11.2-1 amd64

Everything is unstable with this update

prosody 0.11.2-1+deb10u1 amd64

This is indeed a security update that installed automatically

I was found this in /var/log/apt/history.log

Start-Date: 2021-05-19 06:19:29
Commandline: /usr/bin/unattended-upgrade
Upgrade: prosody:amd64 (0.11.2-1, 0.11.2-1+deb10u1)
End-Date: 2021-05-19 06:19:30

We did not modify the parameter “mod_limits” is in default state.

Thanks

If you have mod_limits enabled you need to adjust default as those limit the jicofo connection a lot.

Adjust it to:

limits = {
    c2s = {
        rate = "512kb/s";
    };
}

Hello,

This is work fine now.

Thanks

Thanks for confirming I’m working on a permanent solution by default: