Room crashed when somebody joined

I just did a quick install on ubuntu 18.04 and everything worked without a problem.

I followed the quick-install.md

On a fresh installation on Ubuntu 16.04 LTS, in /etc/jitsi/videobridge/config the entry JVB_OPTS="" was empty there.

The same at my fresh installation. The entry JVB_OPTS="" is empty in Ubuntu 18.04 LTS.

So do i need to change it to JVB_OPTS="–apis=xmpp,rest" or does i need to look like JVB_OPTS="" --apis=xmpp,rest ?

By the way the JVB_HOST= is empty too.

Does this topic refers to following?:

New Installation Ubuntu 18.04 LTS the /var/log/jitsi/jvb.log is geeting bigger every minute. less jvb.log | grep WARN gives me:

JVB 2020-03-23 12:18:33.480 WARNING: [195] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:33.488 WARNING: [204] org.jitsi.xmpp.component.ComponentBase.log() PROCESSING TIME LIMIT EXCEEDED - it took 142ms to process: 50:51:5C:F6:36:17:DA:8D:36:02:C4:F7:D6:1B:70:72:5E:D0:98:D3:27:DA:A0:A7:D2:37:D2:27:29:FE:05:78
JVB 2020-03-23 12:18:33.495 WARNING: [195] org.jitsi.xmpp.component.ComponentBase.log() PROCESSING TIME LIMIT EXCEEDED - it took 515ms to process: 2C:AC:7D:62:D3:19:D1:9D:FB:14:E7:E6:2A:B5:9C:49:FA:2E:08:AB:D0:74:4B:27:B0:89:2F:F5:DB:D5:0B:21
JVB 2020-03-23 12:18:33.580 WARNING: [205] org.jitsi.xmpp.component.ComponentBase.log() PROCESSING TIME LIMIT EXCEEDED - it took 160ms to process: 50:51:5C:F6:36:17:DA:8D:36:02:C4:F7:D6:1B:70:72:5E:D0:98:D3:27:DA:A0:A7:D2:37:D2:27:29:FE:05:78
JVB 2020-03-23 12:18:34.476 WARNING: [220] org.jitsi.impl.neomedia.transform.dtls.DatagramTransportImpl.log() Unknown DTLS handshake message type: -116
JVB 2020-03-23 12:18:34.598 WARNING: [17] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with d2dd29af not ready yet.
JVB 2020-03-23 12:18:34.604 WARNING: [17] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:34.604 WARNING: [17] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:34.604 WARNING: [17] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:34.622 WARNING: [244] org.jitsi.impl.neomedia.transform.dtls.DatagramTransportImpl.log() Unknown DTLS handshake message type: -106
JVB 2020-03-23 12:18:34.631 WARNING: [244] org.jitsi.impl.neomedia.transform.dtls.DatagramTransportImpl.log() Unknown DTLS handshake message type: -55
JVB 2020-03-23 12:18:34.903 WARNING: [250] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:34.903 WARNING: [250] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:34.961 WARNING: [250] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:34.961 WARNING: [250] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:36.627 WARNING: [287] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:36.628 WARNING: [287] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:38.567 WARNING: [289] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:38.567 WARNING: [289] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:40.564 WARNING: [290] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:40.564 WARNING: [290] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:41.521 WARNING: [291] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:41.524 WARNING: [291] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:42.574 WARNING: [292] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:42.574 WARNING: [292] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:44.562 WARNING: [293] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:44.563 WARNING: [293] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:56.815 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with 519b376d8874f887 not ready yet.
JVB 2020-03-23 12:18:56.815 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:56.823 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with 7cf3969dc7138df2 not ready yet.
JVB 2020-03-23 12:18:56.824 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:18:56.905 WARNING: [53] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:18:56.906 WARNING: [286] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:18:57.759 WARNING: [157] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with c7c57c6c not ready yet.
JVB 2020-03-23 12:18:57.761 WARNING: [157] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:19:09.223 WARNING: [191] org.ice4j.socket.MergingDatagramSocket.log() Removing the active socket. Won’t be able to send until a new one is elected.
JVB 2020-03-23 12:19:47.337 WARNING: [286] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:19:47.338 WARNING: [53] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:20:07.385 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with 3033b4a6e69d3952 not ready yet.
JVB 2020-03-23 12:20:07.385 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:20:07.515 WARNING: [286] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:20:07.516 WARNING: [53] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:20:27.654 WARNING: [53] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:20:57.952 WARNING: [53] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:22:08.498 WARNING: [753] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:22:08.499 WARNING: [754] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:22:18.511 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with 9d1318061d8baa54 not ready yet.
JVB 2020-03-23 12:22:18.511 WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
JVB 2020-03-23 12:22:18.583 WARNING: [754] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!
JVB 2020-03-23 12:22:18.584 WARNING: [753] org.ice4j.ice.Agent.log() Agent contains no IceMediaStream with name stream!

That is correct.

It is ok, it defaults to localhost.

1 Like

I suffer from about the same phenomenon, but within a different setup source: docker-jitsi-meet. I get video and audio from a second participiant for 1-3 seconds, and then it crashes 100% reproducible.

That setup defines JVB_ENABLE_APIS as none. Given this discussion, it ought to be something else, and env.example carries:

#JVB_ENABLE_APIS=rest,colibri

but no combination of xmpp, rest, colibri does change the behavior. :frowning_face:

The logs are full of:

1993:jvb_1      | JVB 2020-03-25 16:40:37.191 SEVERE: [30] org.jitsi.videobridge.health.Health.log() Health check failed in 0ms:
2003:jvb_1      | JVB 2020-03-25 16:40:41.954 SEVERE: [36] org.jitsi.meet.ComponentMain.call().299 java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5275
2247:jvb_1      | JVB 2020-03-25 16:40:46.955 SEVERE: [36] org.jitsi.meet.ComponentMain.call().299 java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5275
2275:jvb_1      | JVB 2020-03-25 16:40:47.192 SEVERE: [30] org.jitsi.videobridge.health.Health.log() Health check failed in 1ms:
2347:jvb_1      | JVB 2020-03-25 16:40:51.956 SEVERE: [36] org.jitsi.meet.ComponentMain.call().299 java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5275
2372:jvb_1      | JVB 2020-03-25 16:40:56.957 SEVERE: [36] org.jitsi.meet.ComponentMain.call().299 java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5275
2396:jvb_1      | JVB 2020-03-25 16:40:57.192 SEVERE: [30] org.jitsi.videobridge.health.Health.log() Health check failed in 0ms:
2406:jvb_1      | JVB 2020-03-25 16:41:01.958 SEVERE: [36] org.jitsi.meet.ComponentMain.call().299 java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5275
2455:jvb_1      | JVB 2020-03-25 16:41:06.959 SEVERE: [36] org.jitsi.meet.ComponentMain.call().299 java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5275

but I haven’t even found a sign, what service the ominous port 5275 should be.

The docker layout is this:

          Name              Command   State                        Ports                      
----------------------------------------------------------------------------------------------
dockerjitsimeet_jicofo_1    /init     Up                                                      
dockerjitsimeet_jvb_1       /init     Up      0.0.0.0:10000->10000/udp, 0.0.0.0:4443->4443/tcp
dockerjitsimeet_prosody_1   /init     Up      5222/tcp, 5269/tcp, 5280/tcp, 5347/tcp          
dockerjitsimeet_web_1       /init     Up      0.0.0.0:8443->443/tcp, 0.0.0.0:8008->80/tcp     

The http/https posts are a little strange, but this is behind a nginx reverse proxy, that handles ssl already. Full log is available here. The log shows ICE/STUN issues as well, but I’ve not touched those values.

Full config:

CONFIG=~/.jitsi-meet-cfg
HTTP_PORT=8008
HTTPS_PORT=8443
TZ=Europe/Berlin
PUBLIC_URL=https://meet.example.org
DOCKER_HOST_ADDRESS=172.16.23.10
XMPP_DOMAIN=meet.jitsi
XMPP_SERVER=xmpp.meet.jitsi
XMPP_BOSH_URL_BASE=http://xmpp.meet.jitsi:5280
XMPP_AUTH_DOMAIN=auth.meet.jitsi
XMPP_MUC_DOMAIN=muc.meet.jitsi
XMPP_INTERNAL_MUC_DOMAIN=internal-muc.meet.jitsi
XMPP_GUEST_DOMAIN=guest.meet.jitsi
XMPP_MODULES=
XMPP_MUC_MODULES=
XMPP_INTERNAL_MUC_MODULES=
JVB_BREWERY_MUC=jvbbrewery
JVB_AUTH_USER=jvb
JVB_AUTH_PASSWORD=passw0rd
JVB_STUN_SERVERS=stun.l.google.com:19302,stun1.l.google.com:19302,stun2.l.google.com:19302
JVB_PORT=10000
JVB_TCP_HARVESTER_DISABLED=true
JVB_TCP_PORT=4443
JVB_ENABLE_APIS=xmpp,rest
JICOFO_COMPONENT_SECRET=s3cr37
JICOFO_AUTH_USER=focus
JICOFO_AUTH_PASSWORD=passw0rd
JIGASI_XMPP_USER=jigasi
JIGASI_XMPP_PASSWORD=passw0rd
JIGASI_BREWERY_MUC=jigasibrewery
JIGASI_PORT_MIN=20000
JIGASI_PORT_MAX=20050
XMPP_RECORDER_DOMAIN=recorder.meet.jitsi
JIBRI_RECORDER_USER=recorder
JIBRI_RECORDER_PASSWORD=passw0rd
JIBRI_RECORDING_DIR=/config/recordings
JIBRI_FINALIZE_RECORDING_SCRIPT_PATH=/config/finalize.sh
JIBRI_XMPP_USER=jibri
JIBRI_XMPP_PASSWORD=passw0rd
JIBRI_BREWERY_MUC=jibribrewery
JIBRI_PENDING_TIMEOUT=90
JIBRI_STRIP_DOMAIN_JID=muc
JIBRI_LOGS_DIR=/config/logs
DISABLE_HTTPS=1

Any insights are much appreciated.

Filed an issue now.

This issue is fixed now.

The magic trick that solved the issue was commenting out JVB_STUN_SERVERS for us.

1 Like

Just replying to the main topic.
I was struggling with this issue too.
Following the quick install on a debian buster VM.
The weird thing is, when I boot up the VM I the second person cannot join, with the message in jicofo.log:
SEVERE: [29] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant -- no bridge available.

When I restart the jicofo service others can join and also rejoin.
Rebooting the vm to reproduce, and joining is not working again.
Could this be a timing issue in the way the services start?

But how will Jitsi know the public IP?

@ashledombos

But how will Jitsi know the public IP?

Yes, that’s the culprit here. We outwit jitsi by setting DOCKER_HOST_ADDRESS to the public IP for the time being…

Just did a fresh install with the current stable repo, the issue appears to be gone.
jitsi-meet 1.0.4335-1
jitsi-videobridge2

This soled my issue.

Thanks

I use exactly the default setting at https://github.com/jitsi/docker-jitsi-meet, and always crashed if second participant joined.
Then I try restart jicofo, it works.
So why this happened? What can I do if I don’t restart jicofo every time I restart my server.

Try disable TURN

Why you reboot your server? Servers are not made to be rebooted often :confused:

Yes!
It works.Thank you.
I just remarked
JVB_STUN_SERVERS=meet-jit-si-turnrelay.jitsi.net:443
I noticed that when I remarked this out, I can’t use two kinds of browser to use the same camera on the same machine. (Although I think this is meaningless, just for test)
By the way, I don’t want to give another command to make jitsi-meet work appropriatitly.

you’re welcome

Same here on a fresh Debian, adding xmpp,rest fixed it for me.

Hi I am facing the same issue, but I couldn’t get your answer where is JVB_STUN_SERVICES is located and how I should change it. sorry I am new to jitsi. thanks.

Hi I am facing the same issue, my conference automatically gets disconnect just after few seconds the 2nd member joins it. I changed these JVP_OPTS="–apis-xmpp,rest". And then also restarted all prosody, jvp & Jicofo but still its not fixed. conference automatically gets disconnect after few seconds. Thanks.