Role Moderator not visible in local

Hello,
i noticed that since version 7648, i have an anomaly on my platform.

My custom version of Jitsi has the unique moderator, docker-free on secure domain.
The peculiarity is that we have the Lobby room activated by the prosody module, as soon as a room is started, so whoever starts a room is immediately its moderator (and only one).

The prosody log correctly shows that I am the moderator of the room in fact when I start the room, the JitsiConferenceEvents.USER_ROLE_CHANGED of conference.js is correctly triggered (inside it is called just
the dispatch of “localParticipantRoleChanged” and the “notifyUserRoleChanged” which shows me the notification on the screen …)

However, locally my thumbnail does not have the moderator symbol and the Password and Lobby sections are not visible (as if I were a participant …).

Looking at the SecurityDialog.tsx I realized that the “_canEditPassword” calls it
“isLocalParticipantModerator” from react / features / base / participants / functions.ts which returns false because it reads the status within ‘features / base / participants’ and finds in local role a ‘none’ … why?

I noticed that many javascript classes have been translated into typescript, I would not want this to have led to the breaking of some flow that previously worked (in fact my custom merge versioen with the 7577 stable works correctly).

Could you help me solve it?

It is a local issue as this is working on alpha.jitsi.net (always using the latest from unstable repo).
image

You mention you run a custom source version, have you tried running from the version of the debian packages with the same config?

I haven’t tried merging with the latest unstable version. I merged with building 7648.

The symbol (for us a star because we like it more) is seen by the participant …

It is the moderator who in his browser cannot be the moderator because the internal controls at / features / base / participants say his role is “none”.

Do you recommend that I upgrade to the latest unstable version?

No

I recommend running 7648 from debian packages with your config, to see how it goes.

my customizations are inside the code and need to be compiled. Cannot install from debian packages.
I am hooked into github as an external master, and internally merge with my custom master.