Robotic audio on locally recorded webm via meet.jit.si

Jit.si is fantastic and I think the switch to local recording is great. I’ve just noticed that I get robotic audio in the downloaded webm file (Mac, Chrome). Everything sounds great during the call, but in the recording either some or all of the participants sound like robots. Here is an example video.

Considering audio is fine during the call, might this be a compression issue? Have you experienced this and maybe have some tips to try? I am not sure what to do here.

Thanks in advance.

Sounds like everyone’s audio but yours (I assume you are the one who created the recording) is duplicated. @robertpin WDYT?

@gbks what OS are you on?

Thanks for looking into this. I’m on the latest MacOS, using Chrome. And yes, I created the recording.

We suspect it might be because of the tab audio. Could you try to uncheck the Share Audio option from the Chrome Share Picker?

For The Record: we have fixed this in master / alpha already.

2 Likes

Thank you. Disabling that checkbox fixes it.

Getting another issue now where my own video ends up being recorded horizontally flipped. See here for an example where the Jitsi UI is correct, but my video is flipped. Do you maybe know what the reason could be?

There is an option on the 3 dots on your local video to flip it. That is a local operation.

Thanks. In my situation, the video was just fine during the call, but it was flipped in the recording. Does flipping that switch apply to both?

Ah not sure about this … @saghul @robertpin any idea?

That background must be a virtual camera, right? You are supposed to see it mirrored locally, and remote should be seeing it ok. Maybe a setting needs to be toggled in that virtual camera?

It looks correct during the call, both to me and the other attendees. But it is flipped in the recorded video. I use the mmhmm camera.

That’s really odd, local recordings just records your tab as it’s being displayed to you. We change nothing regarding the layout.