Restrict room creation and change language

Dear all,

I am just getting known about setting jitsi meet on self hosting service.
I used Debian 10 and setup based on the guide I found.

Everything works great but I have some addtional questions:
1.)
At first I wanted to translate some text (that introduction screen you get at first) and it worked great. Then suddenly it changed back to english. I know about the option “autodetect language” and I have it disabled. I also set the language in /etc/jetsi/meet/.
I see the language is set to the one I want if I look at config when web page loads, but it does not show the right text. Its always in english.
Do you have any new suggestions? Thank you.

2.)
When the web page first opens, there is introduction screen on which you can create a room.
I want to disable this option and set it so you can create room only if you have user/password. How can I do that?
I enabled user/pass on Prosody but thats not a good solution, because then you need to give that user/pass to every user and when he knows it, he can then again use it to create new rooms.

Hope I wrote my questions clear enough.

Thank you and BR,
Marc

You can use the token (JWT) authentication with an expiration time then someone with a valid token can join the meeting in a restricted room within a restricted period.