Resolved: Not able to access remote user's desktop after enabling and starting remote control

Hey guys,

I enabled remote control functionality on my end and I can see the remote control being advertised to the browser client and the option is also enabled in the menu. However, when I start remote control and I am granted the permissions, still, I am unable to access anything on the other user’s desktop. Is there anything I am missing? I thought it should work out of the box once it is enabled. Any help will be appreciated here. Thanks.

Hum, is the other user using the electron app?

I feel that someone should point now that this ‘feature’ does not exist, it has been disabled for security reason and it is not supposed to work, it can only be restored by patching the code. It is not recommended to do so.

Yes Damien. The other user is using electron app.

i.e the controlled part is electron app and the controlling side is chrome browser.

Anything here? Any thoughts guys?

So Damien. I added logs in the utils for debugging more. Seems like robot.moveMouse is not working.

RemoteControl **** width  1680
RemoteControl **** height  1050
RemoteControl **** destX  1506.867545298382
RemoteControl **** destY  487.5

Here are the logs I added to see the co-ordinates value for EVENTS.mousemove

And then it is suppose to execute robot.moveMouse(destX, destY); which seems like not happening. I dont’ see any error though. Any idea what might be wrong here? Thanks!

Hey guys, can anyone really help me out here?

Wondering if you could even tell me how to enable the remote function, I’m running a server on Ubuntu 20.04 and have no idea how to turn it on.

Alright. NVM guys. I am able to make remote control thing work. It was an issue from my end!

So Austin, if you are using latest jitsi electron app, you need to make a single line code change to make it work. You can do so as below:

  • Go to app/features/conference/components/Conference.js file.

  • There is a line const ENABLE_REMOTE_CONTROL = false;

  • Change it to true, make a new build and that’s it.

Remote Control should work after that.

Note: The remote control is disabled by jitsi community because of some security issues as described here