<resolved>Cannot build the lib-jitsi-meet.min.js and app.bundle.min.js from Jitsi-meet repo

  1. I have upgrade the NPM and nodejs
    npm -v
    6.9.0
    nodejs -v
    v10.16.3

  2. clone jitsi-meet repo
    git clone https://github.com/jitsi/jitsi-meet.git

  3. CD to jisti-meet
    remove node_module
    run npm install.
    output:

Hash: cea08c273bbb776ea2e2
Version: webpack 4.26.1
Child
Hash: cea08c273bbb776ea2e2
Time: 24918ms
Built at: 09/16/2019 8:54:56 AM
Asset Size Chunks Chunk Names
lib-jitsi-meet.min.js 661 KiB 0 [emitted] lib-jitsi-meet
lib-jitsi-meet.min.map 2.54 MiB 0 [emitted] lib-jitsi-meet
Entrypoint lib-jitsi-meet = lib-jitsi-meet.min.js lib-jitsi-meet.min.map
[2] ./JitsiConferenceEvents.js 8.63 KiB {0} [built]
[3] ./modules/browser/index.js 98 bytes {0} [built]
[4] …/jitsi-meet-logger/lib/index.js 3.83 KiB {0} [built]
[5] ./modules/statistics/statistics.js 28.5 KiB {0} [built]
[8] ./service/statistics/AnalyticsEvents.js 17.1 KiB {0} [built]
[9] ./service/RTC/MediaType.js 110 bytes {0} [built]
[11] ./modules/util/GlobalOnErrorHandler.js 2.37 KiB {0} [built]
[12] ./JitsiTrackErrors.js 2.51 KiB {0} [built]
[13] ./modules/RTC/RTC.js 35.4 KiB {0} [built]
[15] ./JitsiTrackError.js 5.95 KiB {0} [built]
[16] ./JitsiTrackEvents.js 1.31 KiB {0} [built]
[17] ./JitsiConferenceErrors.js 2.12 KiB {0} [built]
[20] ./modules/videosipgw/VideoSIPGWConstants.js 1.44 KiB {0} [built]
[119] ./index.js 160 bytes {0} [built]
[120] ./JitsiMeetJS.js 19.7 KiB {0} [built]
+ 137 hidden modules

node-sass@4.10.0 postinstall /opt/jitsi-meet/node_modules/node-sass
node scripts/build.js

Binary found at /opt/jitsi-meet/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
Binary is fine
npm WARN lifecycle jitsi-meet@0.0.0~postinstall: cannot run in wd jitsi-meet@0.0.0 jetify (wd=/opt/jitsi-meet)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/jest-haste-map/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

  1. run “make”
    ./node_modules/.bin/webpack -p
    Makefile:18: recipe for target ‘compile’ failed
    make: *** [compile] Killed

some js file have been created in the build folder
image

but lib-jitsi-meet.min.js and app.bundle.min.js are not created

resolved by increasing VM to 4 CPU and 8G mem