RESOLVED Authentication prosody is failing and mic + video blocked

Hi all,

I installed Jitsi on a VPS today. I’ve done this before so a bit confused about the issues I’m currently experiencing. I probably missed something.

There are 2 issues:

  • no authentication enforced whilst this is set up, following the documentation on Digital Ocean
  • video and mic are off by default upon entering the room and cannot be enabled

I followed the documentation to a T and set up prosody as well as created a user account using prosodyctl but when navigating to the domain (using the Brave browser and Chrome) it let’s me create a room without authenticating. Really curious what I’m missing.

I set everything up properly to enable authentication here:

/etc/prosody/conf.avail/name-of-my-domain.cfg.lua
/etc/jitsi/meet/name-of-my-domain-config.js

So domain, anonymousdomain as well as authdomain are set.

In /etc/jitsi/jicofo/sip-communicator.properties I added this to make sure Firefox users cannot create a room without authenticating: org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true

I’m out of ideas, so I hope someone knows what I’ve missed.

Many thanks and best,
Deborah

your browser is a special case, there was a thread about this a few days ago, you need to set some parameter to avoid skipping the login window - does not mean that authentication does not work, it’s just that the auth window is hidden, the meeting is not really created. Do your tests with another browser or the Electron app instead.

Additionaly, secure domain need also this change in jicofo config
sudo sh -c “echo ‘org.jitsi.jicofo.auth.URL=XMPP:yoururl.yourtld’ >> /etc/jitsi/jicofo/sip-communicator.properties”

Usually video and audio can’t be enabled if you are using plain http.

hello, wow, thanks so much for your fast response, that’s really great. I’ll do more tests with another browser, and change the jicofo config. thanks and best,
Deborah

Hello, just to let you know that it’s resolved. Not sure if this was the fix, but it surely seems so.

What I did was adding org.jitsi.jicofo.jibri.SIP_BREWERY=TheSipBrewery@conference.name-of-my-domain.nl to /etc/jitsi/jicofo/sip-communicator.properties which seems to have resolved it in Chrome as well as Brave. Really weird but phew :slight_smile:
thanks for the support and best,
Deborah