[Resolv] Participants cannot see or hear each other problem?

Hello
I have a VM on a local network with Ubuntu 20.04
I folow the tutot : [https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstart](github devops-guide-quickstart)

Some point where not full compliant with the tuto :

  • I did not change the hostname of the VM, but I had External-IP jitsi.mydomain.org jitsi in /etc/hots
    => I can connect from outside of the network to jitsi server
  • I did not NAT the 443 port from the External to the VM, but the job is donne by nginx
  • I had already cerbot certificate so I try to select them (but my files are .pem in stead of the .key required during install, Is it a problem?)
  • I use during install for the hostname “Alternatively you can enter the IP address of the machine” and put the External_IP

The problem :
It is possible to connect from local network or from outisde to the server but each connection does not see anyone…

I have tested the 10000 port from ouside with
Server : sudo tcpdump -ni ens160 udp port 10000 -vv -X
Client : echo ‘yes, it is accessable’ | nc -u jitsi.mydomain.org 10000
=> It works

I have look in the log files but not strange things except maybee :

Jicofo 2020-11-27 10:12:42.635 WARNING: [32] org.jitsi.config.log() Key ‘jicofo.bridge.average-participant-packet-rate-pps’ from source ‘typesafe config’ is deprecated: use jicofo.bridge.average-participant-stress
Jicofo 2020-11-27 10:12:42.643 INFO: [32] org.jitsi.jicofo.bridge.BridgeSelector.log() Added new videobridge: Bridge[jid=jvbbrewery@internal.auth.My-Ext-IP/0471320a-1d31-4e40-bf93-516503fbf2bb, relayId=null, region=null, stress=0.00]
Jicofo 2020-11-27 10:12:42.645 INFO: [32] org.jitsi.jicofo.bridge.JvbDoctor.log() Scheduled health-check task for: jvbbrewery@internal.auth.My-Ext-IP/0471320a-1d31-4e40-bf93-516503fbf2bb
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler (file:/usr/share/jicofo/lib/dom4j-1.6.1.jar) to method com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()
WARNING: Please consider reporting this to the maintainers of org.dom4j.io.SAXContentHandler
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Both should use the same address to connect to Jitsi and this address should be the address which was set during the installation

Both connect to :
https://jitsi.mydomain.org/Test

If all connections are from the internal networks, do they see each others?
Is there problem only when the connections are mixed (internal + external)?

The problem is the same.
The both can be on the local network, or one on local and the other outside.
Both have the same screen :
https://owncloud.schugart.net/s/8So47EfInjIZM7R

Can you turn on the audio/video while you are the only participant?

No the video ou Micro is still cross even if I click on it

But when I click on the little arrow down on the Video button near the end of call I can see my image from the webcam

I thought I would see me only when someone will be connected…

No, the audio/video works while you are alone too.

Could you check the services status

systemctl status prosody
systemctl status jicofo
systemctl status jitsi-videobridge2.service

Is this exactly the same host address while connecting through the browser?

grep server_name /etc/nginx/sites-enabled/*

The 3 services are running and green but there is a red message for prosody :

prosody[1808]: portmanager: Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

this is OK, no problem

The grep command gives :

/etc/nginx/sites-enabled/“My-Ext-IP”.conf:server_names_hash_bucket_size 64;
/etc/nginx/sites-enabled/“My-Ext-IP”.conf: server_name “My-Ext-IP”;
/etc/nginx/sites-enabled/“My-Ext-IP”.conf: server_name “My-Ext-IP”;
/etc/nginx/sites-enabled/default: server_name _;
/etc/nginx/sites-enabled/default:# server_name example.com;
/etc/nginx/sites-enabled/owncloud.conf: server_name owncloud.mydomain.org;
/etc/nginx/sites-enabled/owncloud.conf: return 301 https://$server_name$request_uri;
/etc/nginx/sites-enabled/owncloud.conf: server_name owncloud.mydomain.org;
/etc/nginx/sites-enabled/rutorrent.conf: server_name rutorrent.mydomain.org;

Only the text in bold has been anonimized

as we are arround nginx, some information on my networks :
My-Ext-IP is hosted by a Pfsens wich NAT the 443 port to a VM1
The VM1 has a nginx that forward all jitsi.mydomain.org to the VM2 that host jitsi server

IIUC /etc/nginx/sites-enabled/My-Ext-IP.conf is the config file of Jitsi-Meet. So jitsi works if you use https://My-Ext-IP/room-name as the link

But https://My-Ext-IP/room-name could not works as https + IP is not regular... is it ok if I rename the /etc/nginx/sites-enabled/My-Ext-IP.confto/etc/nginx/sites-enabled/jitsi.mydomain.org.conf`
?

This will not solve the issue. Reinstall Jitsi using jitsi.mydomain.org as a domain name

Wonderfull it works !!!
Thanks a lot

1 Like

I have a similar issue but not entirely the same. We are trying to use Jitsi as an embedded component in our application and we see a problem similar to this one.

  • From our application, we join using a room Id that is auto generated by an api. It works fine when we connect from a local system. But if another user joins the room from outside the network, the connection starts to disconnect and keeps trying to rejoin without any success. This is with embedded component only.
  • If we create/join a meeting from the JITSI default UI, no error is seen. We can conduct our meetings fine. But if anyone joins in from our application, then the errors start popping up.

The wierd thing is we don’t get any errors when we use beta.meet.jit.si as our server. It only happens when we try with our version of jitsi.

Please help.

What is the result when there are “3 participants” from the local system and using the default Jitsi UI