Remove rooms and participants

Hi! Is it possible to remove rooms and participants in jitsi? Currently, I have to restart the service if a participant freezes.
I am using Jitsi-Meet on a Debian-based GNU/Linux system version 2.0.6865-2. 3.
Is it possible to manually remove rooms and participants?

It has been pointed to you on Github that there is a timeout feature that kicks inactive users after one minute. If this is not working for you, post more details and steps that could allow to reproduce the problem.

It freezes for me and doesn’t turn off after 60 seconds. And if you leave the room and go back in, then this participant is still in it. Only restarting jitsi helps. Is it possible to manually remove rooms and participants from CLI using ID rooms or participants?

it should be possible to write a script using the telnet interface (module mod_admin_telnet)

@Owirtifo what is the prosody version you use?

prosody version 0.11.9-2+deb11u2

Did you customize anything in prosody config files?

Is this an upgraded Jitsi or new installation?

Upgraded version. But unfortunately I didn’t install and configure it. In previous versions, the problems are the same.
Prosody configuration:

unlimited_jids = { "focus@auth.example.com", "jvb@auth.example.com" }
plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "example.com";

external_service_secret = "*******";
external_services = {
     { type = "stun", host = "example.com", port = 3478 },
     { type = "turn", host = "example.com", port = 3478, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" },
     { type = "turns", host = "example.com", port = 5349, transport = "tcp", secret = true, ttl = 86400, algorithm = "turn" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

-- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline=5.4
ssl = {
    protocol = "tlsv1_2+";
    ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384"
}

VirtualHost "guest.example.com"
    modules_enabled = {
        "conference_duration";
    }
    authentication = "anonymous"
    c2s_require_encryption = false






VirtualHost "example.com"
    -- enabled = false -- Remove this line to enable this host
    authentication = "ldap2"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    --app_id="example_app_id"
    --app_secret="example_app_secret"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "***";
        certificate = "****";
    }
    speakerstats_component = "speakerstats.example.com"
    conference_duration_component = "conferenceduration.example.com"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.example.com"
    main_muc = "conference.example.com"
    -- muc_lobby_whitelist = { "recorder.example.com" } -- Here we can whitelist jibri to enter lobby enabled rooms

Component "conference.example.com" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        --"token_verification";
    }
    admins = { "focus@auth.example.com" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.example.com" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.example.com", "jvb@auth.example.com" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.example.com"
    modules_enabled = { "limits_exception"; }
    ssl = {
        key = "***";
        certificate = "***";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.example.com" "client_proxy"
    target_address = "focus@auth.example.com"

Component "speakerstats.example.com" "speakerstats_component"
    muc_component = "conference.example.com"

Component "conferenceduration.example.com" "conference_duration_component"
    muc_component = "conference.example.com"

Component "lobby.example.com" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true

Hi! Is it possible to remove rooms and participants in jitsi? Currently, I have to restart the service if a participant freezes.
I am using Jitsi-Meet on a Debian-based GNU/Linux system version 2.0.6865-2. 3.
Is it possible to manually remove rooms and participants?

You can just refresh the screen and re-enter the meeting.

It freezes for me and doesn’t turn off after 60 seconds. And if you leave the room and go back in, then this participant is still in it. Only restarting jitsi helps. Is it possible to manually remove rooms and participants from CLI using ID rooms or participants?