Remove random room name generation animation on welcome page

Hi all,

I’ve currently got a jitsi-meet instance running from source. A weird requirement but is it possible to disable the random room name generation on the welcome page and if so could you possibly guide me on where to disable this? many thanks!

remove this line https://github.com/jitsi/jitsi-meet/blob/master/react/features/welcome/components/WelcomePage.web.js#L207

2 Likes

Thanks!

I cant find the WelcomePage.web.js file on my system where I installed Jitsi already. Any other option to disable the random name creation?

I’m new to Jitsi, but could do this by editing /usr/share/jitsi-meet/interface_config.js

change below value from ‘true’ to ‘false’ ;
GENERATE_ROOMNAMES_ON_WELCOME_PAGE: false,

there is no component restart required post that, verify with browser refresh.

niceee! thanks!

Hi Supun,
How to do this in the apps ?
What folders are needed for repackaging the apps both Android and iOS
Thanks

@Vinod have you managed to remove random room names in apps?

yes i could do that

Can you guide how can I do it in android please

made the following changes in the MainActivity.java:

public void onButtonClick(View v) {
EditText editText = findViewById(R.id.conferenceName);
String text = editText.getText().toString();

    if (text.length() > 0) {
        // Build options object for joining the conference. The SDK will merge the default
        // one we set earlier and this one when joining.
        JitsiMeetConferenceOptions options
                = new JitsiMeetConferenceOptions.Builder()
                .setRoom(text)
                .build();
        // Launch the new activity with the given options. The launch() method takes care
        // of creating the required Intent and passing the options.
        JitsiMeetActivity.launch(this, options);
    }
}

Note: ensure that the text box has some default text otherwise the app will crash

1 Like

Okay thank u soooo much anyway which branch have you used ? Is it master or mobile-19.5?

You may simply disable the random generated text by editing the interface_config.js edit this line
GENERATE_ROOMNAMES_ON_WELCOME_PAGE: true, turn it into false as GENERATE_ROOMNAMES_ON_WELCOME_PAGE: false,

save your file and you will not see the random text generated