Remove / Disable Welcome Page?

Hi!

I set up Jitsi to use with Rocketchat and configured access via token. Everything is working as expected and I followed the secure domain instructions. As well, in my Jitisi config in /etc/prosody/conf.d/i I set autentication=“token”. Now I browse to the web page and try to create a meeting I am prompted for a username and password which is good.

However optimally I’d like to get rid of the start a new meeting input box totally, along with the list of previously created meetings below. My only use with Jitsi is via Rocketchat, so I don’t need/want the default landing page at all. I’d actually prefer a static page with just a bit of text on it. How can I achieve this?

Thanks in advance for any help.

How about dumping users into a random meeting URL?

You can change this in your domain config in /etc/jitsi/meet/ - the js file - to disable the welcome page.

Though I don’t know if you can prevent it from auto-redirecting people into a meeting name.

    // Whether to use a welcome page or not. In case it's false a random room
    // will be joined when no room is specified.
    enableWelcomePage: true,

Take a look at /usr/share/jitsi/meet/interface_config.js.

I’m pretty sure there’s a setting in there to disable the welcome page, although I think it then just loads a random room.

Hi. I did try setting enableWelcomePage to false, and when I did I got the expected behaviour of being placed in a random room. Unfortunately this is also undesirable. Would prefer to have no access at all for non-authenticated users.
.

The secure domain config would mean a random room would still be loaded, but they could not actually start the room.

Did you succeed with this? I also want to disable the welcome page. I want to show just a blank page / 403 if somebody occasionally steps on the meeting-URL. But I also want users, who know jitsi is available, to create and access a room by directly entering the room’s URL.
I tried creating a blank index.html in the document root, but this of course breaks the rooms.

Hello,
i´am looking for the same, somebody with new option?

1 Like

I’m also looking for the same funcationality, so please add my vote to the tally. :wink:

Came here for the same question, was considering the same option as mentioned by kblg, but apparently this method doesn’t work.

@gittinjiggywithit, Welcome to the community!

The interface_config has two options that will change the behavior of the homepage that may serve you needs.

Look at changing
RECENT_LIST_ENABLED and GENERATE_ROOMNAMES_ON_WELCOME_PAGE both to false.

See : https://github.com/jitsi/jitsi-meet/blob/25ae83bcf4c9e2eabf4e4f1e30fbedcda20ab00f/interface_config.js#L103

Also, experiment with
DISPLAY_WELCOME_PAGE_CONTENT and DISPLAY_WELCOME_PAGE_TOOLBAR_ADDITIONAL_CONTENT also in interface_config.

By the way, enableWelcomePage is in config not interface_config . See this reference.

Finally, you can use CSS to easily hide the new room field an button. See this reply for a technique on where to save your custom CSS that doesn’t require compiling from source.

Hope this helps!

1 Like

Hi @corby, thank you, and thank you for your reply!
I’m quite new to Jitsi, so it’s greatly appreciated with some tips.

I’ve experimented a bit with the variables you mentioned in the interface_config.js file on my server.
Setting RECENT_LIST_ENABLED and GENERATE_ROOMNAMES_ON_WELCOME_PAGE to false seems to take effect, but changing the DISPLAY_WELCOME_PAGE_CONTENT and DISPLAY_WELCOME_PAGE_TOOLBAR_ADDITIONAL_CONTENT does not seem to have any effect, at least as far as I can see.

I tried looking for the other config file you provided a reference to, but was unable to find it? For context, I did my installation using the following guide: https://nerdonthestreet.com/wiki?find=Host+a+Jitsi+Meet+Server

I think your CSS solution might be the best strategy for achieving what I want, so I’ll definitely try and give that a shot too.
Thanks again for the tips!

See this guide:

1 Like