Remove Authentication for Host since using tokens

Hi Jitsi Team,

Iam using tokens, and trying to understand if i can remove, the Authentication that comes with “Iam host”. Is it possible.

Thanks
Phani

Any help here will be greatly appreciated.

Please provide the more details then i can help you

Iam using the tokens mechanism to login into jitsi meet. I also have guest domain enabled. When the moderator has not started the conference, and the guest joins the session, he gets a screen

screen1

If iam clicking Iam the host, it asks me

screen2

Since, i dont allow any auth with users directly, i dont want the userid and password screen to be displayed… Is this possible ?

you have to pass jwt token with domain like this https://domain-OR-IP /roomname?jwt= jwt token otherwise it will ask username password

But if am clear that guests, are going to wait for the moderator to join… Since the auth is disabled with user-id, we dont want the “Iam the host” button to be displayed.

how you are identifying that you are a host

With JWT Tokens. I have already configured the JWT for Jitsi

if you provide token guest side also then , Are you able to join ?

Guest is anonymous … Token auth is assumed to be host role

@Raj_Yadav Any help ?

actually i’m looking for this feature, if you fix it may i know how you did that? could you please share you prosody file and config.js ?

Did you fix it? I understand what you mean and I’m looking for a solution too.