Remote participant microphone controls (mute / unmute)

no still nothing.All the build was done from the mute-unmute script and developers script i didnt run it.Nope i cleared cache i rebooted server nothing.Lets see if others are more lucky.

Hello @pratik @pranitshirsath , we forgot to include the changes we made in the language file while we were creating the notes. Therefore, you may be failing in the middleware.

The moderator can now unmute the participant. In this case, you need to fix the alert that you cannot unmute the participant while muting. -> Main.json

"muteParticipantBody": "You can unmute the participant whenever you want.",
"muteParticipantButton": "Mute",
"muteParticipantDialog": "Are you sure you want to mute this participant?",
"muteParticipantTitle": "Mute this participant?",

"unMuteParticipantBody": "You can mute the participant whenever you want",
"unMuteParticipantButton": "Unmute",
"unMuteParticipantDialog": "Are you sure you want to unmute this participant?",
"unMuteParticipantTitle": "Unmute this participant?",

run as root

cd
wget -O build https://raw.githubusercontent.com/emrahcom/emrah-tools/main/jitsi/unmute/5142/build
bash build

Compatibable only with the current stable release, 2.0.5142-1
Don’t use on a production server. It can be harmfull.
Not well tested, tested only on Debian Buster
No warranty, no responsibility
Have some notification message issues

1 Like

emrah where to run this in lxc container or on debian 10 os install?

Both are OK

nope still nothing tried the script but didnt fix anything still no unmute button.I have tried all things from the bayraktarulku repository all this weekend but still nothing.It doesnt show the unmute button.

How did you test after the build?

opened up the chrome and connected and from 2 other devices with chrome on one and jitsi app as guest on other.I even reboot the machine and tested it and also re-run the script after the reboot in lxc container.
Empty the cache of the browsers just in case and delete all cloned repos from bayraktarulku and run only your bash script.
Versions of jitsi are
ii jitsi-archive-keyring 1.0.1 all The public key for the Jitsi packages repository
ii jitsi-meet 2.0.5142-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4466-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4466-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4466-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4466-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-376-g9f12bfe2-1 all WebRTC compatible Selective Forwarding Unit (SFU)

This is only a build script. It doesn’t touch your working system. Even it’s not needed to run it on a Jitsi server.

It’s needed to “copy the changed files to the Jitsi server” or “run jitsi-meet using the development environment” to activate the changes.

Copy these files to the Jitsi server

  • /root/dev/jicofo/target/jicofo-1.1-SNAPSHOT.jar -> /usr/share/jicofo/jicofo.jar
  • /root/dev/jitsi-meet/libs/app.bundle.min.js -> /usr/share/jitsi-meet/libs/
  • /root/dev/jitsi-meet/libs/lib-jitsi-meet.min.js -> /usr/share/jitsi-meet/libs/

Don’t forget to backup the original files before overwrting. Restart the system

I got it working well on Debian 10 buster, It wanst easy. But I have oneproblem. When I change language to my Polish language “Unmute” button is still in english. Where do I have to change it ? I tried in my language file but every notifications of unmute has changed but not the button. I`m attaching picture.unmute

You need to customize the script a bit.

cd /root/dev/jitsi-meet/lang
vim main-pl.json
  • run the make command now
cd /root/dev/jitsi-meet
make
2 Likes

Im sorry but I wasnt using yours script. Do I have to use it ? Now Im havin good working config and dont want to desroy it. This script is making too much thing as I think. I was making changes by editing file : /root/dev/jitsi-meet/lang/main-pl.json and donig command: npm install lib-jitsi-meet --force && make. Everything has change but not the “Unmute” button description.

No need. This is only automize some steps

This is what I suggested but since it doesn’t work, I have no idea for now. Maybe @bayraktarulku has an idea

1 Like

excellent emrah with the reboot and cleared cache now the button appeared and working.Thank you very very much for your effort and help.The only prob is that if you connect from jitsi android app even thought you get the message is isnt unmutting.I thing its already mentioned that it doesnt work with android app.

1 Like

im main-pl.json and donig command: npm install lib-jitsi-meet --force && make . Everything has change but the “Unmute” button description

We added this parameter into main.json and pull it from there. While editing the UnMuteRemoteParticipantDialog.js file instead; Instead of dialog.unMuteParticipantButton & dialog.unMuteParticipantTitle & dialog.unMuteParticipantBody , you can type the comment you want to use in quotes.

File path:

Another method is as @emrah said.

1 Like

@bayraktarulku, @emrah thanks for fast help. The key was path to bayraktarulku/jitsi-meet/blob/mute-unmute/react/features/remote-video-menu/components/web/UnMuteRemoteParticipantDialog.js . Of course on my server it is a littl edifferent. I had to make change in : https://github.com/bayraktarulku/jitsi-meet/blob/mute-unmute/react/features/remote-video-menu/components/web/UnMuteButton.js, exaxctly in here:

buttonText = { t('Unmute') }

And the button title now is translated.

Now I only need to remember about it durng upgrade :slight_smile:

1 Like