Rekey of letsencrypt

I am currently operating a jitsi server.
I got the certificate with letsencrypt before installing jitsi.
I tried to rekey for the first time because letsencrypt’s 3 months expired, but it didn’t work.
I’ve verified that the jitsi server is receiving HTTP queries from the internet for verification, but the jitsi server is returning an error.

I contacted the Letsencrypt Community and they recommended a root location of /var/www/html.
But the root location has been rewritten by jitsi to /usr/share/jitsi-meet.
How can I update the key in this situation?

I’m not sure I understand the issue correctly but if the root location is the issue and if this server hosts only jitsi you may link /var/www/html to jitsi home.

mv /var/www/html /var/www/html.old
ln -s /usr/share/jitsi-meet /var/www/html

By default with old code that manages let’s encrypt a cron job is installed that should take care of the renew.
With the new one (acme.sh) it is also managed internally and renewed when needed.

Thanks for your comments.
Key update was successful by changing the webroot.
I’ve been struggling with this for the past week.
This time, I got the certificate while the root was /var/www/html.
After that, the root was switched by installing jitsi, but letsencrypt tried to renew without knowing this.

This sounds like some miss configuration in the web part.