Reinstalled Jitsi, but now calls do not relay participants

I set up a Jitsi instance and have been a (very satisfied!) Jitsi user and admin ever since. Due to a hardware issue, however, I had to reinstall; I installed my system following the Debian/Ubuntu server instructions in the self-hosting guide.
Installation was smooth and I found no errors (as expected). However, when trying to start a call, the participants do notice of each other (this is, the “square” with the other person’s initial does appear), but audio and video are not relayed – each participant stays with a view of their own camera, and the other participant’s initials only. No audio gets “through” either.
Text-only chat between participants works.
I am attaching the four log files I think might matter — jicofo.log, jvb.log, nginx/access.log and prosody.log. I know the truth must be somewhere in there, but I don’t know what to look for :frowning:
Any help will be most welcome!

PS- I tried to upload the log files, but it seems that’s against this forum’s logic. In any case, I have them here for the next three months:
jicofo.log → debian Pastezone
jvb.log → debian Pastezone
nginx/access.log → debian Pastezone
prosody.log → debian Pastezone

PS- The forum is not allowing me to upload my log files; I’ll try to attach them after creating the topic.

Make sure you configure again the port forwarding of udp 10000 from public address to the new machine.

As I said, this instance used to work correctly. I have UDP port 10000 open in my firewall, with a non-RFC1918 IP address.

So this is the machine that has the actual public address? I was suspecting you have a new internal address for the new machine and need to update the NAT settings for the port forwarding.

Any js console logs errors in the browser?

Umh :confused: I’ll have to say “sorry for the noise”, or probably re-file this as a different request.

Before bugging my coworkers into testing this as a multiparty conference, I tried to establish this between my computer and my phone, and it behaved as I described. But I managed to try and open from two different computers – It worked fine! I just had a talk with two of my coworkers.

However, two of us tried to join the call from our phones (I tried with the Jitsi Android app, the other one tried with the browser in the phone. Both failed to show any other participants’ images, failed to join the audio conversation, and failed to send the phone video to the rest of the participants.

But the happy news is – The server works correcty!

What version of Jitsi are you running?
Are you using your old config files or did you reinstall everything fresh?

I reinstalled fresh; I have jitsi-meet-{prosody,turnserver,web,web-config} version 1.0.6991-1, jitsi-meet 2.0.8319-1 and jitsi-videobride2 2.2-79-gf6426ea0-1.

If this is the current version as you state, you shouldn’t need these lines, but just in case, try adding the following to your config.js and see if that helps:

config.flags = {};
config.flags.sourceNameSignaling = true;
config.flags.sendMultipleVideoStreams = true;
config.flags.receiveMultipleVideoStreams = true;

They are already part of the vendor-supplied config file :smiling_face:

They are listed under the following header:

// Temporary backwards compatibility with old mobile clients.

Can you open 3 tabs in same meeting, does it work that way?

I tried opening two different desktop browsers and connecting from my mobile (don’t want to be bothering my coworkers); audio, video and screen sharing work correctly between the browsers (of course, only one of them can grab the camera simultaneously), but the phone does not get any content from either.

The phone client I have is just updated, 22.7.1 build 12419976. As I said, I also tried from the phone using the browser.

You can open chrome and open 3 tabs in it using the same room link, you don’t need mobile app and colleagues.
Sounds like the port forwarding to jvb is not working or some firewall is stopping the media to reach jvb.

That works correctly. I will try later from home, with a couple of different devices (and traversing a layer of NAT) and will report back on my findings…

If 3 tabs work ok (and you are not in same network with jvb) this means there is no network problem as I mentioned above …hum

OK, fair point. Three tabs do work, but I am currently in the same network as my jvb. I will check from home to make sure

OK, I can now confirm: Calls work correctly from outside networks, even crossing NAT!
This issue can be now marked as closed.
Thanks for your help!