Reinstall jitsi meet error audio muted and video muted


#1

Hi team,
I reinstall jitsi meet with quick install guide.
Create meeting, with 2 participant system ok. When 3 participant every particiapant audio muted and video muted.
Pls help me resolve that problem.

Thanks,


#2

Usually this means your JVB is not working properly. What error do you see in the JS console? Please restart the JVB and give it another go.


#3

Hi @saghul,
Thanks for reply. jvb error is correct.

But i restart jvb, jicofo and prosody but it is still not work.
Pls help me check it.


#4

Hi @saghul,
And this is my detail warning and error in console.

Thanks,


#5

The log you pasted happens when the conference is hang up. Can you please paste the log when the 3 participants join? Also, have you restarted the videobridge?


#6

Hi @saghul,
That is console log of 3rd participant screen.
I restared jvb.

[modules/e2eping/e2eping.js] : Initializing e2e ping; pingInterval=10000, analyticsInterval=60000.
Logger.js:125 [modules/connectivity/ParticipantConnectionStatus.js] : RtcMuteTimeout set to: 2000
Logger.js:125 [modules/statistics/AvgRTPStatsReporter.js] : Avg RTP stats will be calculated every 15 samples
Logger.js:125 [JitsiConference.js] : backToP2PDelay: 5
Logger.js:125 [JitsiConference.js] <i._doReplaceTrack>: _doReplaceTrack - no JVB JingleSession
Logger.js:125 [JitsiConference.js] <i._doReplaceTrack>: _doReplaceTrack - no P2P JingleSession
Logger.js:125 [JitsiConference.js] <i._doReplaceTrack>: _doReplaceTrack - no JVB JingleSession
Logger.js:125 [JitsiConference.js] <i._doReplaceTrack>: _doReplaceTrack - no P2P JingleSession
Logger.js:125 [modules/xmpp/moderator.js] <i.setFocusUserJid>: Focus jid set to: undefined
Logger.js:125 [modules/xmpp/moderator.js] <i.createConferenceIq>: Session ID: null machine UID: 98bbfa9e9a281626674c16c85560b115
app.bundle.min.js?v=3081:1 [react/features/base/tracks/actions.js] <>: Replace audio track - unmuted
app.bundle.min.js?v=3081:1 [react/features/base/tracks/actions.js] <>: Replace video track - unmuted
Logger.js:125 [modules/xmpp/strophe.jingle.js] <>: getting turn credentials failed <iq xmlns=​"jabber:​client" type=​"error" to=​"8808aff0-7a17-4a98-8bec-1754f2499f24@vc1.xxx.vn/​cd4f1b7a-2b7c-47ad-92cd-be890382a0e2" from=​"vc1.xxx.vn" id=​"5370d6fd-b0c9-43ec-8d79-9e3cb58de631:​sendIQ">​…​​
n @ Logger.js:125
Logger.js:125 [modules/xmpp/strophe.jingle.js] <>: is mod_turncredentials or similar installed?
n @ Logger.js:125
Logger.js:125 [modules/xmpp/strophe.ping.js] <a.value>: XMPP pings will be sent every 10000 ms
Logger.js:125 [modules/xmpp/moderator.js] <i.setFocusUserJid>: Focus jid set to: focus@auth.vc1.xxx.vn
Logger.js:125 [modules/xmpp/moderator.js] <i.parseConfigOptions>: Authentication enabled: false
Logger.js:125 [modules/xmpp/moderator.js] <i.parseConfigOptions>: External authentication enabled: false
Logger.js:125 [modules/xmpp/moderator.js] <i.parseConfigOptions>: Sip gateway enabled: false
Logger.js:125 [modules/xmpp/ChatRoom.js] <t.value>: entered entermeetingnameormeetingid@conference.vc1.xxx.vn/64531b37 Object
app.bundle.min.js?v=3081:1 [conference.js] <r.>: USER 64531b37 connnected: e
Logger.js:125 [modules/xmpp/ChatRoom.js] <t.value>: entered entermeetingnameormeetingid@conference.vc1.xxx.vn/ddd44bd1 Object
app.bundle.min.js?v=3081:1 [react/features/base/storage/PersistenceRegistry.js] <n.value>: redux state persisted. c0440dd1705d137ce23b8f325302c0a0 -> 577af131c1cdbee76a87f58674b22700
app.bundle.min.js?v=3081:1 [conference.js] <r.>: USER ddd44bd1 connnected: e
app.bundle.min.js?v=3081:1 [conference.js] <r.>: My role changed, new role: none
Logger.js:125 [modules/xmpp/ChatRoom.js] <t.value>: (TIME) MUC joined: 2531.7999999970198
app.bundle.min.js?v=3081:1 [react/features/local-recording/controller/RecordingController.js] <n.value>: Recording format switched to flac
Logger.js:125 [modules/xmpp/ChatRoom.js] <t.value>: Subject is changed to
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
n @ Logger.js:125
app.bundle.min.js?v=3081:1 Uncaught (in promise) DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
n @ Logger.js:125
app.bundle.min.js?v=3081:1 Uncaught (in promise) DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
app.bundle.min.js?v=3081:1 [modules/UI/videolayout/LargeVideoManager.js] <>: hover in %s 8808aff0
12Logger.js:125 [JitsiConference.js] <e.sendMessage>: Failed to send a ping request or response.

Thanks,


#7

Is that all you get? I can’t see any CONFERENCE_FAILED event there…


#8

Hi @damencho ,
Can you review to help me resolve that error.
I reinstall jitsi meet with quick install guide.
Create meeting, with 2 participant system ok. When 3 participant every particiapant audio muted and video muted.

Thanks,


#9

This is not a fatal error, it is just a warning that mod_turncredentials is not configured in prosody, so no turn servers will be added to the peer connection. Turn servers are needed in special restricted firewall cases, but by default everything should work with them.


#10

Hi @damencho,
That right because the meeting is normal with 2 participants (p2p).
But if more 3 participants join to a meeting every one change to audio muted and camera muted.
I dont know why? jvb config is wrong?
How can i fix that problem?
That is firewall status on my server:

$ufw status
Status: active

To Action From


Apache Full ALLOW Anywhere
OpenSSH ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
3306 ALLOW Anywhere
Apache Full (v6) ALLOW Anywhere (v6)
OpenSSH (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)
3306 (v6) ALLOW Anywhere (v6)

Thanks,


#11

Are you running your JVB behind nat? Have you followed the advance part of the quick install https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration


#12

It is not only firewall. Is the public address used for your deployment available on the machine running the jvb? If you do ipconfig do you see the public ip address?


#13

Hi @damencho,

No. I install all in one server.


#14

That does not matter. Whether it is one or more. If you do ipconfig do you see the public ip address pf your deployment?


#15

Hi @damencho
That is net info. What do i have to config with network?

_# ifconfig
ens3 Link encap:Ethernet HWaddr 56:00:01:be:e6:ba
inet addr:207.xxx.xxx.205 Bcast:207.xxx.xxx.255 Mask:255.255.254.0
inet6 addr: fe80::5400:xxx:xxx:e6ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4284590 errors:0 dropped:0 overruns:0 frame:0
TX packets:1844324 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2227240240 (2.2 GB) TX bytes:1821437923 (1.8 GB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:2121158 errors:0 dropped:0 overruns:0 frame:0
TX packets:2121158 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:374877436 (374.8 MB) TX bytes:374877436 (374.8 MB)
_

Thanks,


#16

Hi @damencho,
I active local IP and add NAT config to sip-communication of jvb.
file /etc/jitsi/videobridge/sip-communicator.properties :
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.vc1.xxx.vn/.*
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=10.xx.xx.xx
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=207.xxx.xxx.xxx

Ifconfig information:
ens3 Link encap:Ethernet HWaddr 56:00:01:be:e6:ba
inet addr:207.xxx.xxx.xxx Bcast:207.xxx.xxx.xxx Mask:255.255.254.0
inet6 addr: fe80::xxxxxxxxxxxx:e6ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3403 errors:0 dropped:0 overruns:0 frame:0
TX packets:1695 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:512055 (512.0 KB) TX bytes:945071 (945.0 KB)

ens7 Link encap:Ethernet HWaddr 5a:00:01:be:e6:ba
inet addr:10.xx.xx.xx Bcast:10.xx.xx.xx Mask:255.255.240.0
inet6 addr: fe80::xxxxxxxxxxx:e6ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1450 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:726 (726.0 B) TX bytes:578 (578.0 B)

But it is still wrong.

Thanks,


#17

I also encountered the same problem, but do not know how to solve, welcome to discuss


#18

Hi @damencho,
That is error on jvb log.
I dont know why did i meet this error.
-----------------------------jvb log----------------------------

Pls, help me resolve it.

Thanks,


#19

This aws harvester can be disabled, but the error you seeis harmless and you can ignore it.


#20

Hi @damencho,
Thanks for reply but i can not fix this error.
Could you help me. The videobridge config is below.
Addition why
Addition, your mean is no problem with _ rg.ice4j.ice.harvest.AwsCandidateHarvester.obtainEC2Addresses() String for local IP: null_

Thanks so much.