Refesh and lost moderator

Hello, i have some problems in config jitsi: i had done “Secure Domain setup” and successed: who have account will be moderator. but when i refesh the tab few times, i lost my moderator permission. I cant understand and how to fix. i used token based authentication: JWT:
jicofo {
authentication: {
enabled: true
type: JWT
login-url: jitsi-meet.example.com
}

A hacky solution is to set XMPP as type

do you know how to config only one host per meet?

This depends on your use case. For example this (one moderator per meet) is the default behaviour when the authentication is anonymous.

i set type xmpp but anyone had had moderator will be moderator when start meet then will have more one moderator per meet

I think I’m a bit confused. Are you saying when you used Secure Domain, you were losing Moderator privileges on browser refresh? Or that you’re experiencing this when you use JWT?

Jicofo has an authorization lifetime, meaning, how long it recognizes the authenticated user on the client (if the cache is not cleared). By default, this is set to 24hrs. If you haven’t specifically changed that, you shouldn’t be experiencing what you’re reporting. The other option is autologin in Jicofo; if you disable that, you will also lose Moderator privileges when you disconnect. Both of these options are set in jicofo.conf:

i use type JWT because it will refesh cache if room not exist and admin will login when create room. but when admin wait few minutes and refesh tab, admin lost moderator permission and become normal client. I I fixed it according to you but it still doesn’t work

  • Do you have guest users (participants without JWT)?

  • Why is “more than one moderator” a problem in your use case since they have valid tokens?

i have guest users. i want to have only one moderator for managing meeting. but there seems to be some problem like i mentioned above

You may create JWT only for the moderators and allow the others to join as guest.

problem of me is refesh and lost moderator. according to you will be success?

Works for me when type is XMPP

1 Like