Reduce video quality of android client

Hi:
I modified the server configuration config.js and set 180p, but it did not work on android client.
thanks!

Hi @Vagretyao and welcome to our community!

That’s right, it’s a limitation we currently have. The resolution settings are ignored and 720p is used at all times.

Thank you for your reply.
Is the resolution of videobridge control or libjitsi decoding control?
Which part of the code can I refer to?

This is on the client side. We always open the camera at 720p on mobile devices. You’d need to edit react-native-webrtc

Thank you very much for your reply.

Is video captured by android client in VP8 or H264 format?

What is the encoding format and configuration for streaming video from the server to the android client?

Where can I modify this encoding format for testing?

libjitsi\src\org\jitsi\impl\neomedia\codec\video

You can change those options in config.js in your Jitsi Meet deployment.

VP9 is not supported.

I am quoting another post to reply to this post, end it

It works!!

@Vagretyao, mind sharing what you did to get it working? I have posted here with what I’ve done. Any pointers appreciated!

I’m just limiting the maximum.
This is not a good plan.