Redirect URL on hangup?

Is there a way to redirect to a specified URL on hangup without using the API? I have a self hosted jitsi.

If so, can anyone walk me through it? I’m not too technical.

Thank you!


I found this but don’t understand where I can execute and revise this?

You can enable the close page, which will load close2.html, and you could customize that. Toggle “enableClosePage” to true in config.js

I found this but don’t understand where I can execute and revise this?

You can enable the close page, which will load close2.html, and you could customize that. Toggle “enableClosePage” to true in config.js

I haven’t tried it myself, but the file you want to edit is /usr/share/jitsi-meet/interface_config.js

Open that file, and look for:

SHOW_PROMOTIONAL_CLOSE_PAGE: false,

Change that to “true”.

Here’s the bit I’m less sure about from reading the jitsi code. I think that you want to edit close3.html in /usr/share/jitsi-meet/static/ and add whatever you want.

Thank you @Neil_Brown :slight_smile:

Going to give it a go now.

If that doesn’t work, then have a look in /etc/jitsi/meet/config.js — that’s where “enableClosePage” is available. I don’t know which file contains the resulting page though.

I was able to find this using /usr/share/jitsi-meet/static/

image

Not sure how to edit this though. As when try to backspace or delete it wants to close out.

Yes, that’s right: /usr/share/jitsi-meet/static/close3.html (at least, I think it’s the right file).

How you edit it depends on what operating system you are running (and what your preferred text editor is).

Give this a try:

nano /usr/share/jitsi-meet/static/close3.html

Personally, I like vim:

vim /usr/share/jitsi-meet/static/close3.html

Hmm… it doesn’t want to allow me to inline edit this. Directory shows up no problem though.

Depending on what account you are logged in as, you might need to run the editor as a superuser. Again, this depends on your operating system, but try:

sudo nano /usr/share/jitsi-meet/static/close3.html

Ah ok. Entering in that last one brought this up:

I appreciate you taking the time. I’m not too technical so my apologies in advance.

That looks correct to me — by default, it’s an empty file.

If you add just the word “test” into it, the save the file and exit (which is, I think Control + O in nano), what happens if when you exit a jitsi conference? (Assuming you’ve made the config change to either or both config.js or interface_config.js.)

So I tired test, and also tried entering a URL into that same screen to see if it made a difference. Ending a meeting returns back to the normal ‘enter meeting’ screen.

I changed the config to

SHOW_PROMOTIONAL_CLOSE_PAGE:true,

Edit: I think I’m getting closer. It doesn’t want to redirect though.

I also had to enable

enableClosePage:true,

image

Code for the meeting termination is here: https://github.com/jitsi/jitsi-meet/blob/0289a93e5a900f993b65a1b9165b07882da6e29e/react/features/app/actions.js

If enableClosePage is true, the system will redirect to static/close2.html after the meeting ends.

If the SHOW_PROMOTIONAL_CLOSE_PAGE option is true, you get close3.html

So, the easiest way to redirect a user after the meeting closes is to enable the close3.html page, then have it be nothing but a refresh.

In /etc/jitsi/meet/(your server config), set the following line:

enableClosePage: true,

In /usr/share/jitsi-meet/interface_config.js, set the following line:

SHOW_PROMOTIONAL_CLOSE_PAGE: true,

Now, make your /usr/share/jitsi-meet/static/close3.html page look something like this:

<html>
	<head>
		<meta http-equiv="refresh" content="0; url=http://example.com/" />
	</head>
</html>

You should now have a redirect to example.com as soon as the meeting closes! Adjust as needed.

//EDIT: Set the SPCP variable to true…

4 Likes

THANK YOU!!! Worked like a charm. :slightly_smiling_face:

Hi, we are trying on this, and if I change two variables (for embed Jitsi Meet) in API configOverwrite and interfaceConfigOverwrite sections, dont work ;-((

Any idea??

Thanks in advance

Any idea about this please?

I trying in API too, it’s not working. The promotional page is still there :frowning:

Any ideas?

There are events like readyToClose and videoConferenceLeft which can be used to hide/remove the iframe and present something else.

Making SHOW_PROMOTIONAL_CLOSE_PAGE to true, but close3.html doesn’t start :frowning:

Any idea ?

Yeah, I’m having the same issue.