Recordings failed to start!

Hello! I have problem with Jibri !!
I installed Jitsi and Jibri in ubuntu 18.04
when click on recording have notification recordings preparing to record … after a few seconds I have error recordings failed to start .
Jibri create folder in my record root and create file metadata.json but not recording

log.0.txt (54.5 KB)

Jibri was unable to join the call. This is usually due to incorrect authentication information, either:

  1. You don’t have the credentials for the various xmpp domains configured correctly in jibri or
  2. You didn’t create the accounts correctly in prosody

I’d check those two things.

the accounts correctly in prosody

> prosodyctl register jibri auth.jitsi.example.com password
> prosodyctl register recorder recorder.jitsi.example.com password

Prosody.cfg.lua :

jibri {
  // A unique identifier for this Jibri
  // TODO: eventually this will be required with no default
  id = ""
  // Whether or not Jibri should return to idle state after handling
  // (successfully or unsuccessfully) a request.  A value of 'true'
  // here means that a Jibri will NOT return back to the IDLE state
  // and will need to be restarted in order to be used again.
  single-use-mode = false
  api {
    http {
      external-api-port = 2222
      internal-api-port = 3333
    }
    xmpp {
      // See example_xmpp_envs.conf for an example of what is expected here
      environments = [
        {
          name = "test demo"
          xmpp-server-hosts = ["meet.islamfond.ru"]
          xmpp-domain = "meet.islamfond.ru"

          control-muc {
            domain = "internal.auth.meet.islamfond.ru"
            room-name = "JibriBrewery"
            nickname = "jibri"
          }

          control-login {
            domain = "auth.meet.islamfond.ru"
            username = "jibri"
            password = "password"
          }

          call-login {
            domain = "recorder.meet.islamfond.ru"
            username = "recorder"
            password = "password"
          }

          strip-from-room-domain = ""
          usage-timeout = 0

          trust-all-xmpp-certs = true
        }
      ]
    }
  }
  recording {
    recordings-directory = "/recordings"
    finalize-script = ""
  }
  streaming {
    // A list of regex patterns for allowed RTMP URLs.  The RTMP URL used
    // when starting a stream must match at least one of the patterns in
    // this list.
    rtmp-allow-list = [
      // By default, all services are allowed
      ".*"
    ]
  }
  chrome {
    // The flags which will be passed to chromium when launching
    flags = [
      "--use-fake-ui-for-media-stream",
      "--start-maximized",
      "--kiosk",
      "--enabled",
      "--disable-infobars",
      "--autoplay-policy=no-user-gesture-required"
    ]
  }
  stats {
    enable-stats-d = true
  }
  webhook {
    // A list of subscribers interested in receiving webhook events
    subscribers = []
  }
  jwt-info {
    // The path to a .pem file which will be used to sign JWT tokens used in webhook
    // requests.  If not set, no JWT will be added to webhook requests.
    # signing-key-path = "/path/to/key.pem"

    // The kid to use as part of the JWT
    # kid = "key-id"

    // The issuer of the JWT
    # issuer = "issuer"

    // The audience of the JWT
    # audience = "audience"

    // The TTL of each generated JWT.  Can't be less than 10 minutes.
    # ttl = 1 hour
  }
  call-status-checks {
    // If all clients have their audio and video muted and if Jibri does not
    // detect any data stream (audio or video) comming in, it will stop
    // recording after NO_MEDIA_TIMEOUT expires.
    no-media-timeout = 30 seconds

    // If all clients have their audio and video muted, Jibri consideres this
    // as an empty call and stops the recording after ALL_MUTED_TIMEOUT expires.
    all-muted-timeout = 10 minutes

    // When detecting if a call is empty, Jibri takes into consideration for how
    // long the call has been empty already. If it has been empty for more than
    // DEFAULT_CALL_EMPTY_TIMEOUT, it will consider it empty and stop the recording.
    default-call-empty-timeout = 30 seconds
  }
}

I think in Jibri.conf have mistake ???

Your domains are different between the Jibri config and the prosodyctl commands?

no ! same
prosodyctl register jibri auth.meet.islamfond.ru password
prosodyctl register recorder recorder.meet.islamfond.ru password

try this

strip-from-room-domain = "conference."
1 Like

thanks its working