Recording unavailable

jibri log

2020-04-22 00:45:03.979 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2020-04-22 00:45:04.008 WARNING: [21] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2020-04-22 00:45:04.076 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.
2020-04-22 00:45:09.067 WARNING: [21] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=XXXXX hostname=XXXXX] error connecting
org.jivesoftware.smack.SmackException$NoResponseException: No response received within reply timeout. Timeout was 5000ms (~5s). While waiting for establishing TLS
at org.jivesoftware.smack.SmackException$NoResponseException.newWith(SmackException.java:93)
at org.jivesoftware.smack.SynchronizationPoint.checkForResponse(SynchronizationPoint.java:272)
at org.jivesoftware.smack.SynchronizationPoint.checkIfSuccessOrWait(SynchronizationPoint.java:157)
at org.jivesoftware.smack.SynchronizationPoint.checkIfSuccessOrWaitOrThrow(SynchronizationPoint.java:128)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectInternal(XMPPTCPConnection.java:908)
at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:383)
at org.jitsi.xmpp.mucclient.MucClient.lambda$getConnectAndLoginCallable$7(MucClient.java:638)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

jitsi & jibri server use java 8
image

jitsi SSL. is valid from let’s encrypt free ssl

Please help me.

why not have this error same me.
I’m searching 2 day ago.

:cry: :cry: :cry:

I solved this problem.
jibri record working now.
Thank you.

:smiley:

please can you help how you solve this problem

I encountered this problem at the security equipment (IPS).
I tried to check all config many times. But nothing is wrong.
So I asked the administrator to investigate and found the problem.
I request open the policy between jitsi and jibri servers so it works well.

what do you mean by policy , should i asked AWS adminsisterator to open the policy between two servers?

I do not use AWS. I use server in my office.
I recommend check config between jitsi-meet and jibri server.
Jibri server will try to connect jitsi with port 5222.
May be disable ufw.