Recording Unavailable


#1

Hi,

I installed Jitsi-meet and Jibri on Ubuntu 16.04 EC2 instance by refering the below documentation and guide. Configured the domain name with the ip address.
I’m able to test jitsi-meet with creating and joining to the room. However, after installing jibri and configuring, I’m getting Recording Unavailable error.

I have attached the screenshot and Jibri log. Looking at Jibri log it seems XMPPConnection was not successful.

2018-07-08 22:58:20.200 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2018-07-08 22:58:21.437 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/srv/recordings, enabledStatsD=true, finalizeRecordingScriptPath=/path/to/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServer$
2018-07-08 22:58:22.335 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does$
2018-07-08 22:58:22.871 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on 18.221.190.79 with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[18.2$
2018-07-08 22:58:22.886 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2018-07-08 22:58:52.929 WARNING: [21] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2018-07-08 22:58:52.981 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses fai$
2018-07-08 22:58:53.074 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement an$

================================================================================
Please guide to resolve this issue.

Thanks,
Venky


#2

This is an issue. It looks like the log message got clipped but Jibri is failing to connect to your xmpp server.


#3

@bbaldino How can I fix this?


#4

I can better answer that if you paste the entire error message from the log.


#5

That’s all I have it from the log. I copy pasted the entire log.


#6

Do you have a logging config file? What does it look like? The messages appear to be getting truncated.


#7

2018-07-08 22:58:20.200 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2018-07-08 22:58:21.437 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/srv/recordings, enabledStatsD=true, finalizeRecordingScriptPath=/path/to/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[18.221.190.79], xmppDomain=18.221.190.79, controlLogin=XmppCredentials(domain=auth.18.221.190.79, username=jibri, password=jibriauthpass), controlMuc=XmppMuc(domain=internal.auth.18.221.190.79, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.18.221.190.79, username=recorder, password=jibrirecorderpass), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)])
2018-07-08 22:58:22.335 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2018-07-08 22:58:22.871 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on 18.221.190.79 with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[18.221.190.79], xmppDomain=18.221.190.79, controlLogin=XmppCredentials(domain=auth.18.221.190.79, username=jibri, password=jibriauthpass), controlMuc=XmppMuc(domain=internal.auth.18.221.190.79, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.18.221.190.79, username=recorder, password=jibrirecorderpass), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2018-07-08 22:58:22.886 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2018-07-08 22:58:52.929 WARNING: [21] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2018-07-08 22:58:52.981 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘18.221.190.79:5222’ failed because: /18.221.190.79 exception: java.net.SocketTimeoutException: connect timed out
2018-07-08 22:58:53.074 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.


#9

This looks better?


2018-07-08 22:58:20.200 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2018-07-08 22:58:21.437 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/srv/recordings, enabledStatsD=true, finalizeRecordingScriptPath=/path/to/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[18.221.190.79], xmppDomain=18.221.190.79, controlLogin=XmppCredentials(domain=auth.18.221.190.79, username=jibri, password=jibriauthpass), controlMuc=XmppMuc(domain=internal.auth.18.221.190.79, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.18.221.190.79, username=recorder, password=jibrirecorderpass), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)])
2018-07-08 22:58:22.335 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2018-07-08 22:58:22.871 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on 18.221.190.79 with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[18.221.190.79], xmppDomain=18.221.190.79, controlLogin=XmppCredentials(domain=auth.18.221.190.79, username=jibri, password=jibriauthpass), controlMuc=XmppMuc(domain=internal.auth.18.221.190.79, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.18.221.190.79, username=recorder, password=jibrirecorderpass), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2018-07-08 22:58:22.886 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2018-07-08 22:58:52.929 WARNING: [21] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2018-07-08 22:58:52.981 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘18.221.190.79:5222’ failed because: /18.221.190.79 exception: java.net.SocketTimeoutException: connect timed out
2018-07-08 22:58:53.074 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.



#10

This is your problem. Jibri can’t connect to your xmpp server.


#11

What might have went wrong?


#12

AFAIK EC2 have no sound module on their kernels.
Maybe you could use another VPS with support to continue testing.


#13

Has this issue been solved @venky ?