Recording Unavailable error

Can anyone help me with this error please? I’ve got Jibri set up and running. When I click record in Meet I get a ‘Recording Unavailable’ error. Here is the Jibri log:

2018-12-30 07:27:11.240 INFO: [1] org.jitsi.jibri.Main.main() Jibri run with args [--config, /etc/jitsi/jibri/config.json]
2018-12-30 07:27:11.245 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2018-12-30 07:27:11.246 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2018-12-30 07:27:11.247 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for the HTTP API
2018-12-30 07:27:11.849 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/tmp/recordings, enabledStatsD=true, finalizeRecordingScriptPath=/home/jibri/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=jibri-2 environment, xmppServerHosts=[meet.example.org], xmppDomain=meet.example.org, controlLogin=XmppCredentials(domain=auth.meet.example.org, username=jibri, password=jibriauthpass-R6nqMEP3eb2r), controlMuc=XmppMuc(domain=internal.auth.meet.example.org, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.meet.example.org, username=recorder, password=jibrirecorderpass-R6nqMEP3eb2r), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)])
2018-12-30 07:27:12.411 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2018-12-30 07:27:12.711 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on meet.example.org with config XmppEnvironmentConfig(name=jibri-2 environment, xmppServerHosts=[meet.example.org], xmppDomain=meet.example.org, controlLogin=XmppCredentials(domain=auth.meet.example.org, username=jibri, password=jibriauthpass-R6nqMEP3eb2r), controlMuc=XmppMuc(domain=internal.auth.meet.example.org, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.meet.example.org, username=recorder, password=jibrirecorderpass-R6nqMEP3eb2r), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2018-12-30 07:27:12.719 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2018-12-30 07:27:42.739 WARNING: [21] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2018-12-30 07:27:42.807 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: 'meet.example.org:5222' failed because: meet.example.org/x.x.x.x exception: java.net.SocketTimeoutException: connect timed out
2018-12-30 07:27:42.879 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.
2018-12-30 10:01:44.016 INFO: [17] org.jitsi.jibri.api.http.internal.InternalHttpApi.gracefulShutdown() Jibri gracefully shutting down

This is the output of service jibri status
service jibri status

● jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
   Active: active (running) since Mon 2018-12-31 07:38:15 UTC; 55s ago
 Main PID: 1404 (java)
    Tasks: 31
   Memory: 166.3M
      CPU: 4.207s
   CGroup: /system.slice/jibri.service
           └─1404 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/jibri/jibri.jar --config /etc/jitsi/jibri/config.json

Dec 31 07:38:18 jibri-2 launch.sh[1404]: 2018-12-31 07:38:18.758 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP s
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.786 WARNING: [21] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.871 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.Smac
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.874:WARN:oejsh.ContextHandler:main: o.e.j.s.ServletContextHandler@1ad926d3{/,null,null} contextPath ends with /*
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.874:WARN:oejsh.ContextHandler:main: Empty contextPath
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.875:INFO:oejs.Server:main: jetty-9.2.z-SNAPSHOT
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.915 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.945:INFO:oejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@1ad926d3{/,null,AVAILABLE}
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.946:INFO:oejs.ServerConnector:main: Started ServerConnector@4f449e8f{HTTP/1.1}{0.0.0.0:2222}
Dec 31 07:38:48 jibri-2 launch.sh[1404]: 2018-12-31 07:38:48.947:INFO:oejs.Server:main: Started @33502ms

And service jitsi-xorg status

● jibri-xorg.service - Jibri Xorg Process
   Loaded: loaded (/etc/systemd/system/jibri-xorg.service; disabled; vendor preset: enabled)
   Active: active (running) since Mon 2018-12-31 07:38:15 UTC; 3min 58s ago
 Main PID: 1407 (Xorg)
    Tasks: 3
   Memory: 49.8M
      CPU: 116ms
   CGroup: /system.slice/jibri-xorg.service
           └─1407 /usr/lib/xorg/Xorg -nocursor -noreset +extension RANDR +extension RENDER -logfile /tmp/xorg.log -config /etc/jitsi/jibri/xorg-video-dummy.conf :0

Dec 31 07:38:15 jibri-2 Xorg[1407]: xorg-server 2:1.18.4-0ubuntu0.8 (For technical support please see http://www.ubuntu.com/support)
Dec 31 07:38:15 jibri-2 Xorg[1407]: Current version of pixman: 0.33.6
Dec 31 07:38:15 jibri-2 Xorg[1407]:         Before reporting problems, check http://wiki.x.org
Dec 31 07:38:15 jibri-2 Xorg[1407]:         to make sure that you have the latest version.
Dec 31 07:38:15 jibri-2 Xorg[1407]: Markers: (--) probed, (**) from config file, (==) default setting,
Dec 31 07:38:15 jibri-2 Xorg[1407]:         (++) from command line, (!!) notice, (II) informational,
Dec 31 07:38:15 jibri-2 Xorg[1407]:         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Dec 31 07:38:15 jibri-2 Xorg[1407]: (++) Log file: "/tmp/xorg.log", Time: Mon Dec 31 07:38:15 2018
Dec 31 07:38:15 jibri-2 Xorg[1407]: (++) Using config file: "/etc/jitsi/jibri/xorg-video-dummy.conf"
Dec 31 07:38:15 jibri-2 Xorg[1407]: (==) Using system config directory "/usr/share/X11/xorg.conf.d"

Hi @MattB98,

can you please share the versions of the Jibri and Jicofo, Jvb are you using? Please make sure all the components are updated to the latest version.

Abhijit

Are you sure the Jibri and Jicofo are connected.? Make sure the user/pass you entered in prosody are the same as your config.json for jibri. Also stop jicofo and jibri and start jibri followed by jicofo.

Abhijit

Thank you Abhjit

I updated Jibri, Jicofo and Jvb all within the last week, so they will be at the latest versions. I’ve run back through the prosody setup, the user/pass is all set up as per the config.json.

The last line of your Jibri logs show it shutting down, which would obviously be a problem, but I’m assuming you ran your tests before it shut down?

Try doing this: clear the jicofo and jibri logs, then restart jicofo and then jibri and attach both sets of logs here.

Same problem here.

Jicofo 1.0.-440-1 stable version + java version “1.8.0_151”
Jibri 7.1.70-1 unstable version + openjdk version “1.8.0_191”

jicofo 440 will not work with latest jibri, you need to have everything updated from unstable. I hope to update stable next week.

1 Like

Oh Ok. We’re only allowed to use stable versions of Jitsi packages within our company.
Thanks for the feedback and I hope the next stable version will be ready soon :pray:

@damencho is the stable is updated with jicofo version that will work with latest jibri ?